How to fix errors after Studio Community Edition auto-updated from 2019.8 to 2019.9

This short tutorial will teach you how to fix your Studio Community Edition if it misbehaves after the auto-update.

Observed Behavior

The Robot is unable to execute a process or is disconnected from Orchestrator after you update to v2019.9 Studio Community Edition from v2019.8 via the auto-update option.

Cause

This issue occurs if the Robot Agent (Tray) is active during the update. After the update is complete, one of the following exceptions is thrown:

  1. GetUserStatus timed out - when you start a process

  2. The operation was canceled - when the Robot gets disconnected from Orchestrator and is unable to reconnect.

Solution:

For both scenarios, the solution is to terminate the UiPath.Service.UserHost.exe service.

image

And this is all you have to do if your Studio does not work after auto update :slight_smile:

Alternatively, a computer restart will work just as well.

17 Likes
Error : GetUserStatus TimedOut
The operation was canceled on Community Orchestrator
Don´t can start the execution with new version UiPath Studio 2019.9.0
Unable to connect orchestrator
2019.9.2 CE STUDIOから実行出来なくなった。
Orchestrator URL
Introducing UiPath Studio, StudioX, Explorer Expert & Cloud Orchestrator 2019 Preview
The operation was canceeld
Unable to connect UiPath robot to orchestrator
Connecting orchestrator to robot
Uipathでデバッグするときに「GetUserStatus timed out」が出てくる
How to fix your Studio installation / Licensing issues
OrchestratorとRobotを接続することができない
Am getting "Unable to start execution error "GetUserStatus time out"" while excuting a process
Cannot connect orchestrator to Robot
Not able to connect orchestrator to my robot....please help
Not able to Provision the bot with Orchestrator with 2019.9.2 version
Operation was cancelled error while connecting machine to orchestrator
How to connect the robot in Orchestrator settings?
It is time to listen to you! - Studio 2019.10 Preview - Feedback
Error in executing a activity in latest version of Uipath studio 2019.9.262
Can some one help to configure orchestrator..I am receiving the error
Unable to connect orchestrator
Error : GetUserStatus TimedOut
Process not stopping on given breakpoints while running in debug mode
Cant connect uipath robot
Robot is becoming unresposnive after some time in community version
Community Editionでワークフローが実行できない
How to activate Licence of Community Edition version of UIPath
Debuger not working in V2019.8.0
Not able to kill jobs which are stopped
Unable to run the job error: GetUserStatus Time out
I am getting an error named "GetUserStatus"
Just updated to the latest 2019.9.2 version studio window is transparent
UiPath Studio Community Edition doesn't work
Unable to Connect to Orchestrator OCT 2019
UiPath 2019.9 Beta is now available!
UiPath robot to orchestrator connection- "A task was cancelled" error
Error in Orchestrator chaining
Robot cannot connect to Orchestrator
Connecting the Robot in Windows 10 failed while same working windows 7
The question about robot setting in orchestrator
Machine robot connect error Invalid machine key
Regarding machine key
Regarding Bot modification
Deploy the process to Orchestrator

It works, thanks!

2 Likes

Unfortunately, the solution does not work for me since I don’t have UiPath.Service.UserHost.exe service in my Task Manager. Is there any other solution to this problem?
I can’t run any process via UiPath Studio :frowning:

1 Like

Hi @NobodySpeak

Welcome to our UiPath Forum! :slight_smile:

You can give your Studio a clean install by following this guide here:

Please let us know if you still experience some issues.

@loginerror

Hello,
I am always getting the same issue but when i tried to go with your solution, It is not showing me the service option.

1 Like

Another fix for this is to ensure that you do not have multiple installs for UiPath on your system. Go to ‘Add and Remove Programs’ and check to see if there are multiple instances of UiPath Studio. If there is, remove the older install.

2 Likes

Thank you i have followed this information successfully configured in Orchestrator

1 Like

Is there any other way? I can’t terminate UiPath.Service.UserHost.exe service given that I do not have the administer rights. Please advise.

Hi @Derek_Yap

Welcome to our UiPath Forum! :slight_smile:

I would suggest a computer restart.

I believe that the issue comes from the fact that the service was not properly restarted at the time of installation. However, next time it starts it should start properly, which means a computer restart should work here just as well :slight_smile:

2 Likes

Hi,

I have tried re-installed the community version and restart the laptop. It does not work at all.

Hi @Derek_Yap
Could you share your error message?

Hi I am getting this error message “Get User status timed out” lot of times when I run the uipath program. Then I have to manually kill UiPath.Service.UserHost.exe. and then run the program. Do we have any solution to avoid this?

Hi @vasanth8891

How often does it happen? Could you let us know if it is still happening after the latest 2019.10 was installed and your computer was restarted?

1 Like

I had this same issue, terminated the service executable, and restarted, neither fixed the issue.
To resolve it i uninstalled uipath, deleted the C:\Users\%username%\AppData\Local\UiPath folder,
then reinstalled, now all is ok!

This issue is occurring when I am running the bots using different version of UiRobot.exe.
E.g I was using between 19.8.0 & 19.10.0.
Running from cmd line using C:\Users\$$$$$$\AppData\Local\UiPath\app-19.8.0\UiRobot.exe" and later running from Uipath studio which uses “C:\Users\$$$$$\AppData\Local\UiPath\app-19.10.0\UiRobot.exe”.
Hence to avoid this I updated the version in cmd line arguments. This solved the problem.

1 Like

I am getting the error while i debug a work flow

Hi @Swagasmini_Jena

The solution to the error is in the first post of this topic :slight_smile:

1 Like