UiPath Studio Community Edition doesn't work


I installed the Community Edition of UiPath Studio this week, but I can’t run any workflows.
Also when starting the application, it takes a really long time untill I can actually do something.

This is the error I get

I already tried to reinstall studio, but it doesn’t help. Even uninstalling doesn’t work.
I’m using a windows 10 machine in a corporate domain.

Kind Regards

Hi @Tim_D_haeyer,
Welcome to the Community!
It’s hard to say what can be the problem here. As you mentioned it’s corporate machine. I think you should at first talk with your company IT, maybe they have some restriction through GPO applied.

I have the same problem.
Only before it worked for me then after a restart of the Computer I realized before that the projects were saved only in part or not saved (after having saved them carefully).
After Uipath Studio it didn’t work anymore.

I tried to Uninstall it and then reinstall it but nothing.
How can I proceed.

Thank you,


I forgot to add that for me it is also a corporate computer and I have already heard our IT.

Hi @Tim_D_haeyer

Maybe you can refer solution in below article:

I tried to kill that process already, but I can’t find it in my list.
I did check the event viewer and see following error message.

Application: UiPath.Service.UserHost.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: NLog.NLogConfigurationException
at NLog.Config.XmlLoggingConfiguration.ParseLoggerElement(NLog.Config.NLogXmlElement, System.Collections.Generic.IList1<NLog.Config.LoggingRule>) at NLog.Config.XmlLoggingConfiguration.ParseRulesElement(NLog.Config.NLogXmlElement, System.Collections.Generic.IList1<NLog.Config.LoggingRule>)
at NLog.Config.XmlLoggingConfiguration.ParseNLogElement(NLog.Config.NLogXmlElement, System.String)
at NLog.Config.XmlLoggingConfiguration.ParseTopLevel(NLog.Config.NLogXmlElement, System.String)
at NLog.Config.XmlLoggingConfiguration.Initialize(System.Xml.XmlReader, System.String, Boolean)
at NLog.Config.XmlLoggingConfiguration…ctor(System.String)
at NLog.LogFactory.LoadLoggingConfiguration(System.String)
at NLog.LogFactory.get_Configuration()
at NLog.LogFactory.GetLogger(LoggerCacheKey)
at NLog.LogFactory.GetLogger(System.String)
at NLog.LogManager.GetLogger(System.String)
at NLog.NLogTraceListener.ProcessLogEventInfo(NLog.LogLevel, System.String, System.String, System.Object, System.Nullable1<Int32>, System.Nullable1<System.Diagnostics.TraceEventType>, System.Nullable`1<System.Guid>)
at NLog.NLogTraceListener.WriteLine(System.String)
at System.Diagnostics.TraceInternal.WriteLine(System.String)
at UiPath.Robot.Core.AppBootstrapper.OnWinAppStartup(System.Object, System.Windows.StartupEventArgs)
at UiPath.Service.UserHost.UserServiceBootstrapper.Main()

Which version of .Net Framework do you have?


Just a note, I have a colleague who is running an older version of UiPath studio without issues. His version is 2019.8.0

Any update on this? I’m still unable to run any robots.

I’m not 100% sure but it still look for me rather like a local PC issue that something related to software. Meanwhile on platform.uipath.com there is new 2019.9.2 version available. Please try with it using this instruction:

@Pablito No same result. Are there things that I can check to find out what the problem could be? If I go to our infra team to check the GPO’s they will not be able to help me without more information. :slight_smile:

Hmmm you could check with your colleague your configuration between the machines. Maybe there is a difference with user permissions. If he has the same machine config (I assume this).

Normally my machine should be in a “less restrictive” OU in our AD. Meaning that not all group policies apply to my machine. Mainly because I’m already developing in Visual Studio.
I don’t really know where to start looking for the issue. Any hints are welcome!

If you have access or contact with IT in your company maybe they could compare your account with your colleague account and their restrictions etc.

I found the issue. I had an older version of NLog in the GAC of my machine. I replaced it with the newer version that ships with UiPath studio and it works.

1 Like

Can you describe a little more. It’s interesting and I would like to know more in case of similar situation like this :slight_smile:

@Pablito Well I started looking a bit more in detail to the error messages that I saw in the event log. It was clearly pointing to NLog.
I’m a BizTalk developer myself and I have quite some things in the GAC of my machine because of that.
So I checked the version of the NLog DLL that was in the GAC (C:\Windows\Microsoft.NET\assembly\GAC_MSIL) and it seemed to be an older version than the one that is in the UiPath studio folder.
I put that version in the GAC and it works.

So this means that, allthough there is a dll in the UiPath Studio folder, it takes the one from the GAC at runtime. How the Runtime Locates Assemblies - .NET Framework | Microsoft Learn

Not sure if there is any way to force to use the local reference instead of the GAC. But your developers can probably find that out. :slight_smile:

Is it possible that you have installed or updated GAC recently? What I’m thinking is that maybe library was registered on top of the UiPath’s library during installation/update.