Getting "Connected Unlicensed" with Uipath Assistant for new community orchestrator(no Default folder, having only shared folder)(Confusion in machine configuration)

Hi,

I am using New community orchestrator and i created this orchestrator in march,2021. So as per the previous announcement, there is no classic folder here after. Based on Deploying Unattended Robots - Community License above url, I am trying to configure my orchestrator settings in my system. I have below queries. Kindly clarify.

  1. I don’t have Default folder in my orchestrator, In that for modern folder, should I create standard Machine or machine template?. I have created machine templated and I got the machine key. I have used machine key to configure my orchestrator settings. but I am getting Connected unlicensed. Please find the below screenshot.


  1. As per the documentation , I have created machines from shared folder only. shared–>Machines–>Manage assigned machines->Creating machine template. I did the same , but getting connected unlicensed


  1. Should I create robot for this machine template. As per the documentation ,I have done that also. created dummy user from home–>Admin–>users and group–>invite users–>provided dummy email id(unatteded.user@domain.com).

    4.After that created robot for that user from Shared folder–>users -->assign user or group–>user name–>role(robot chosen)–>Clicked Assign.

5.Clicked more option to edit the user . In the user settings, In unatteded Robot -->enabled “Automatically create an unattended robot for this user”–>Provided current system user name (got user name from cmd by typing whoami-desktop-9ot0rji\sathy)–>windows password–>clicked update

I have worked only “Default” folder. Kindly help me how to work with shared folder.

Thanks,
Stalin

@Stalin_R

Check below for your reference

Hope this may help you

Thanks

as per user suggestion I have gone through the link and Robots, by using above link I have updated in the user details page , I have updated Users->User details->role–>Allow to be a automated user and User->robot settings->Auto download process “Yes” , made these change for recently created user.




Now the robot available in tenent->robots page. But machine is not linked with robot. Check below screenshot. Under machine column no machine tagged. Still the issue not solved “Getting connected unlicensed in Uipath assistant”


Any standard procedure to link local machine with new orchestrator???

@Stalin_R

Can you share the Studio version screenshot?

Thanks

I am using 2020.10.6 version and when I am uploading process to orchestrator I am getting below error


Please try to create a new folder and set it up the same way (remember to clean the setup for the folder you made till now)

Hi Pablito,

1.As you said, I have created new folder named as “DESKTOP-9OT0RJI”.
2.Created user with role of robot for this folder
3.Configured User settings,Unattended robot and Robot settings properly
4.Disconnedted and reconnected my orchestrator settings. nbut still connected unlicensed. Can you help me where I am making mistake





For this folder I have added machine also this time



Now I have deleted shared folder and tried now also not working. Still connected unlicesned

Can you try to use only one user. I think this might be a problem.
image

Hi Pablito,

As you suggested , I have deleted one user and kept only one user and tried. But Still , it’s connected unlicensed. My question is, In the DESKTOP-9OT0RJI folder I have linked the created machine but in the tenant–>Robots page, robot is not linked with machine, why is that so… That’s why I think it’s unlicensed. Please refer below screenshot. Kindly help me






Hi @Stalin_R,

Can you hover over the Connected, Unlicensed error in UiPath assistant and share the message you are getting ?

Telling use interactive login

check if you have allocated license. If not allocate the same

Hi @Stalin_R ,

I guess Robot Key authentication is disabled in your orchestrator.

Go to Tenant > Settings > Security tab.

Uncheck, “Enable user authentication, disable robot key authentication” option to connect your machine using Machine Key.


You can refer these URLs and check if you have followed all steps as stated.

Hi @Stalin_R

I think the solution provided by @jithin.gangadharan is the right solution, as per this topic:

Basically, Assistant does not understand unattended licenses yet.

With that said, it’s still possible to connect your robot unattended and using sign-in as long as you configure both attended and unattended for the user, see here for a vanilla setup on a fresh account.

1 Like

Thanks Maciej,

For Unattended - Now it’s connected and licensed . After disabling “Enforce User authentication, disable robot key authentication” option from Tenant–>Settings–>Security

For Attended - Simply sing in from UiPath Assistant, it’s auto creating the attended robot and machine template in orchestrator and “Connected and Licensed”

This url is helpful :Assistant - robot is unlicensed - #11 by Oana_Georgiana_Vasile


Let me publish process and check the processes,job and triggers with this unatteded bot and mark this as solution

Thanks you ,
Stalin

1 Like

Hi Maciej,

I have published one of the process from my studio to orchestrator as tenant feed. But I am facing issue while creating process. Could not create process in any folder. Kindly help me on this



Hi @Stalin_R

I guess user is only having Robot permission for the folder. Go to Tenant > Folders > Folders and check check the permissions for user. If user is having only Robot permission, click on the Edit Role icon and change the permission to “Folder Administrator”.


Hi Jithin,

Thank you so munch man. It worked. I can create process, job and triggers. I am marking this topic as solved




1 Like

Hello Jithin,
I have disable the " Enforce User authentication, disable robot key authentication" and trying to connect. But still it showing Connected and unlicensed (The Machine key is linked to another Machine). Could you help with this issue.
Thanks in Advance…
Error1