Error Message When Attempting to Report an Error Message

Hi,

  1. How do we get support on resolving error messages? I attempted to report an error via the ‘Report a bug’ option in UiPath Orchestrator (cloud.uipath.com).

However, when I click Submit (in ‘Report a bug’) I get the following message: “There was an error trying to submit your feedback. Would you try again?”. I get the same message in both Google Chrome and Firefox.

  1. The main issue I have is as follows:

After signing up to UiPath Community downloading Studio, following through the Unicorn Quick Tutorial and publishing to Orchestrator, I attempted to ‘Start a job’ using the resulting process/automation. This is in UiPath Orchestrator (cloud.uipath.com).

When I click ‘Start’ in ‘Start Job’, however, I get the following message: “Couldn’t find any user with unattended robot permissions in the current folder. (#1671)”

1 Like

Hi @roger1

Welcome to our UiPath Forum :slight_smile:

I will make this post public because it could be information that will prove useful to other users as well.

  1. I was able to easily reproduce this error on my end and I reported it to our team.

  2. First, I am happy that our first run Studio experience went flawlessly for you. Main thing that makes it possible is the default simplified setup that you get out-of-the-box.

    Mainly, by signing up to Orchestrator from your Studio for the first time, you get automatically connected to your Personal Workspace:

    It’s purpose is to be a simplified folder that will get you going, but that will not allow you to run unattended processes. To make that happen, you will need to configure a few more things in Orchestrator.

These are these things:

Making sure your process is in the right place:

  1. First, make sure you publish your processes to the Orchestrator Tenant Processes Feed
    image
    (otherwise it will be set as Orchestrator Personal Workspace Feed, which we don’t want)
  2. Create your process in the Shared folder:
    HowToAddProcess

Making sure your folder settings are correct:

  1. Assign unattended runtime to your machine under Tenant → Machines
    HowToAssignUnattendedRuntime
  2. Enable unattended robot for your user under Tenant → Users
    HowToAddUnattendedToUser
    2a. Fill in the correct domain\username for your machine (this is important, otherwise your processes will be stuck with Pending status when you run them with the auto-generated value). You can grab your domain by running whoami command in your Windows cmd console:
    image
  3. Add your user to the correct folder under Tenant → Folders → Shared → Users
    HowToAddUserToFolder
  4. Add your machine template to your folder under Tenant → Folders → Shared → Machines
    HowToAddTemplateToFolder

You should now be able to run a job on your machine:
HowToRunUnattendedProcess

I hope it’s helpful :slight_smile:

6 Likes

Just an update on your first point - we tracked down the issue and reporting bugs and ideas should now work as expected :slight_smile:

1 Like

Thanks for you reply.

The Unicorn.Quick.Tutorial was created in the My Workspace folder automatically. I can’t see how to move it to the Shared folder. Why do you instruct to create in the Shared folder?

I followed your instructions anyway, then selected ‘Start a job’ for the Unicorn.Quick.Tutorial process in My Workspace, and the Job executed successfully.

The Job type is shown as ‘Attended (RPA Developer)’ however.

Indeed, you can run this process from Orchestrator as attended on your machine either like that or directly from Assistant (much simpler than logging in to your Orchestrator). What you cannot do with the personal workspace is to schedule your processed based on specific triggers so that it starts automatically.

This is why I opted to explain how to configure the Shared folder as this allows you to set a Trigger under Shared folder → Automations → Triggers
See here for more info about triggers:

1 Like

Ok, makes sense thanks.

1 Like

Thank you so much. It was a great topic, because I published my process under (Orchestrator Personal Workspace Feed). Now the state of my process is Successful.

Could I see the process running step by step as I ran it on UI Path Studio.

1 Like

To debug your process, you will have to debug it from Studio. The idea behind running it from Orchestrator is that it will simply run in the background and do its thing.

You can, however, add some checkpoints that will allow you to track what it is doing. The simplest would be to insert a Message Box activity which will display a pop-up at specific times.

More useful for actual processes would be to use the Report Status activity that will display the status of the process in UiPath Assistant as it runs :slight_smile:
image

1 Like

Thanks again for your response. Your steps was so clear for me.

2 Likes