In Uipath assistant: UI Robot Connected But Unlicensed

Hi,

I am using UiPath [Community] studio version 2021.10.3
First, I have created a tenant and clicked on the Orchestrator → Machines → Add new machine -. Add Standard machine and created one
Name: I used the Machine name from Uipath Assisstant
Run time license: Unattended bot as “1”
Then, In Uipath Assistant i have entered the machine key and Orchestration URL and clicked Connect button, its shows Connected but unlicensed

After that i moved to Orchestration → Clicked on Tenant → Folders. I found no default folder is created. So, i created a default folder and clicked on it. Its not showing Robots/Environment tab.

Where i have to correct, please suggest

Hi

Make sure you have created robot for that machine and connect that robot with that machine

Here you go with the steps on how to connect a robot

Once robot is connected unlicensed will get changed as
CONNECTED AND LICENSED

Cheers @Subha_Sundara_moorthi

Hi,
The shared link is useful but i couldn’t find Robot/Environment in Orchestrator.
These options are enabled only in Tenants.
Please find the below screenshot

Hi
Pls check individual folders there we have a separate tab for robots
Click on Default @Subha_Sundara_moorthi

Please find below

Hello @Subha_Sundara_moorthi,

“unlicensed” status for unattended robot in the Assistant is a correct behaviour, if I remember correctly - from 21* versions. So the robot is connected correctly.

If you’d like to do anything on the robot, e.g. run the process from the Assistant, open the process in Studio, you need to configure Troubleshooting session for that robot. You can do this by:

  1. Clicking Tenant->Robots->Unattended session
  2. There you should find the machine which’s connected.
  3. Click on the gear on the right side.
  4. Popup opens, there you can turn on the slider, set how many minutes it should allow you.
  5. Tah-dah, ready. :slight_smile:

After that you should be able to see the robot in “licensed” status, but only for the time that you’ve set up in the Orchestrator.

Best,

Artur

1 Like