Assistant - robot is unlicensed

I have created an unlicensed robot in Community edition and added a standard machine with 1 unattended runtimes. While Orchestrator says that the robot is licensed and I was able to run a process from it, the Assistant says that is unlicensed. Why is this happening?

![3|686x500]

@Oana_Georgiana_Vasile Change robot type to unattended or RPA Developer on the Orchestrator.

Hi @Oana_Georgiana_Vasile

What is the notification that shows when you hover over the Connected, Unlicensed area in your assistant?

“use interactive login”

I have already created an unattended robot in the modern way.

It looks like you should try to Sign In to your Orchestrator instead of using the machine key.

Could you try?

You can always refer to this post:

  1. If I create for my user an attended robot I can connect trough UiPath Assistant, everything works fine, no matter which Connection type I choose in the Assistant. (Machine key or service url)


  2. However, if my user has only an unattended robot I can’t connect to it. I attached some screenshots:
    User config:



    Connect with Service URL:

    Connect with machine key:



I think this issue is happening only in the current community version, I tested with older accounts made on older community versions and issue does not occur.

I discovered how to fix this issue…
If I disable this option I can connect my unattended robot


Is this an expected behavior?

Yes :slight_smile: We are partly to blame here because of the bad feedback we are giving in assistant for unattended robots.

Le me try to explain what is going on, but it’s a bit complicated, I will not blame anyone for failing to understand, it was hard for me too.

I’ll start with the TLDR:

  • with unattended robots only use machine key connection and uncheck the ENFORCE SIGN-IN from Tenant > Settings Security if you want to see processes in Assistant
  • with attended robots - you can use both machine key and sign in

Connecting unattended robot with machine key (so far so good) if ENFORCE SIGN-IN checked (by us, by default for every tenant) :
In this case, the unattended license is actually consumed, you can run unattended jobs but on the assistant interface, because the ENFORCE SIGN-IN is enabled, we are expecting a sign-in, we are in full “attended mode”. We do not show any processes and display use interactive sign-in, even though the unattended robot is working fine.

Connecting unattended robot with service_url >> This is still the case where we are now exclusively searching for an attended robot that does not exist (hence the error). In this case, the unattended license is no longer consumed, you cannot run any jobs.

I say we are partly at fault because so far the robot/assistant was unaware what type of license was given from orchestrator, hence we are giving these confusing error messages.
But we are now working on giving the license type info to assistant and displaying appropriate messages for the user to know why exactly a license is not acquired or why processes do not appear in assistant.

4 Likes

Ok, I understand now the odd behavior. Thanks for taking the time to explain.

And since we discussed about that setting I think it’s a small bug on the checkbox:

3 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.