Orchestrator problems. Studio and Robot no available licenses

Hi all,

I am doing my developer foundation training. I’m at the “Orchestrator for developers” part of the training and I’m stuck there due to some Orchestrator/Robot bug.

I have tried to connect robot to my orchestrator however somehow it’s impossible. When I try connecting I get following outcome:

It says Connected, Unlicensed and when I hover over it, “There are no available licenses on this server” shows up.

I have tried setting everything up, assigning licenses to the machine, assigning machine to the folder, enabling licenses in automation cloud but nothing helped.

When nothing helped I tried deleting existing Tenant and Creating new one - hence the name NotDefaultTenant, I have assigned licenses and everything but the outcome remained the same

I talk with some other developers at my company and it turns out that my account lacks some features for example like in the picture above, when I edit my user there is a dot for creating attended robot missing or as in the picture below there is few options missing while I create a new folder

For comparison that’s how it looks like for other friends in my organization

I thought that maybe I have installed the wrong version of UI Path or it was corrupted, so after uninstalling I have used UIPath Platform Installer instead of Studio Setup this time, however as I finished installation I can’t even log into Studio anymore since it says that there are no available licenses for Studio as well

I have also tried creating another community account but the outcome is similar. It lacks features similarly to the old account.

Is this problem connected to the new users? I have created the account less than 2 weeks ago and all other developers have much older accounts so that’s a clue.
One of the devs tried to do the process from the beginning after reinstalling UI Path and was able to do everything without any problems so that’s another clue.

Could anyone help with the matter please?


As UI Path doesn’t allow new user to post more than 1 media file I have to upload pics in separate comments. Sorry about that

new folder

Hi @hubert.ropa

First things first. Could you please start with a clean Community EXE installation and have a look here:

You will see that the Studio Sign In will simply work for an attended scenario, no need to play around with the machine keys anymore.

The post I linked above also contains this link on how you could potentially setup your unattended license, although it’s a bit of a workaround at this point.

Hi @loginerror thanks for helpful articles.

I have precisely done what you have shown in the first article regarding installation of Studio before trying anything with machine keys. I was able to use studio without any problems however I wasn’t able to create licensed unattended bot - that’s why I have tried using machine key option.

Unfortunately after clean install of studio, I still get the same “There are no available licenses on the server” error

I followed the steps from this post to perform clean reinstall:

Could you please advise?


This specific post should fix that:

Some settings will look slightly different on a new Cloud account, but the crucial bits will be the same.

It comes down to the fact that machine key connection is not fully compatible with the latest changes to the default settings in Orchestrator.
This setting in Orchestrator forces your Assistant and Studio to use the sign in and does not allow for the machine key connection:

This is why it might be easier to workaround it by using the method of connecting your Studio/Assistant as per my post above. It then uses two licenses - the attended which is fully compatible with sign-in for the Assistant/Studio, and unattended runtime to allow you to run processes from Orchestrator on that machine.

@loginerror Thanks for response.

I have found a root to the problem with Studio. When trying different methods yesterday I have disabled licenses for my user in Automation Cloud → Admin → Users and Groups → Edit License Allocation, therefore couldn’t log into Studio as there was no license available for the user.

After I added it back, provided solution worked for me. The only thing which I would change is the Tenant → Robot page in the Orchestrator, I am able to run unattended processes but Unattended Robot is always shown as Not Available which is pretty confusing.

Thanks for the help and happy automation!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.