Robot Unlicensed , There are no available licenses on the server

I am facing a known error i.e Robot Unlicensed.
I have faced similar type of error in the past but this one persists.
I cannot even publish to Orchestrator as there are no available licences.
I have read earlier posts too i.e going to Agent Desktop documents.It says --“There are no available licenses on the server.” - currently, all the available licenses in Orchestrator are consumed.-- so How to undo the available licences
More over in the cloud the robot says available but Robot Tray shows Connected but Unlicensed
I have attached the screenshots.
@loginerror @bcorrea @codemonkee Appreciate any help
Thanks in advance.

1 Like

I am using Community version 19.10.04 stable one

Hi @Jyotirmoy77!

Great level of detail, helps to start offering suggestions! The first thing I would do is from your Agent Desktop hover your mouse over the “Connected, Unlicensed” status message to reveal a more helpful message.

image
As an example “Robot does not exist” would indicate that the Machine and User does not match what is expected or there is no Robot record. So long as the Machine and Username matches it will show Connected, Licensed for a Classic Robot even if the password is wrong.

From your photos

  • You have 2 Attended and 1 Unattended Runtime available
  • You have allocated 1 Unattended Runtime to your Orchestrator instance
  • You are using a Classic Folder
  • You have created a Standard Machine named “DESKTOP-HFT1BGG” allocated with 1 Unattended Runtime

I’m assuming the screenshots were taking at different staging of troubleshooting, noting that the Robot Name and Environments are mismatched between screenshots. But if you are ensuring they are the same, that should be okay.

Although not blocked out, I assume the username of the Robot desktop-hft****\user the hostname portion of it matches the machine name if you are not joined to a domain?

Report back the status message when hovering over with your mouse, should provide some clues.


Something else you can look at is from the License screen, you can click on the See More under Unattended Robots.

image image

From here you can see which Machines are registering under the Unattended and Activate/Disable the machine as well as Click on More Options of the Machine to view the Robots associated with it.

1 Like

Thank you for replying;
As you have mentioned to look at the License screen, & click on the See More under Unattended Robots.
I can see two machines of same name one having Green licencing status and another having Red while I have created only one machine i.e -DESKTOP-HFT1BGG. The one with Green License status shows the Bot associated with it while the other one shows no bot .
When I disable the Red one the bot assocoiated with the Green one gets inactive and the problem still persists. Moreover I have deleted all the created Machine and robot and tried again but it gave no help .
Please help


I have posted the screen shots .

1 Like

@Jyotirmoy77 Can you try changing the Type of Robot to Studio, and then Try Publishing the Workflow to Orchestrator?

1 Like

@supermanPunch Thanks for replying. I am using community version 19.10.04 . As far I know I don’t have any studio licence. But any way I have 1 unattended Bot available and while creating a standard bot I choose Type>> Studio

and got this error >>

@Jyotirmoy77 You can edit the Licenses in the Platform Page as suggested in this post :

2 Likes

@supermanPunch I did every thing @Palaniyappan recommended but the problem persits .

1 Like

Is it some issue with the cloud server maintenance as “Ui path academy” too in not working as expected .

@Jyotirmoy77 Were you able to edit the Licenses for Studio ?

Do yo mean this one

@Jyotirmoy77 Yes, You already have Studio License, So you Should be able to publish the process to the Orchestrator, if the Robot is of Type Studio.

Thankyou @supermanPunch now my bot is connnected after creating Robot Type as >Studio instead of Unattended. But now after Pulishing package to Orchestrator --Creating a Process after selecting the Corresponding Package—While starting a job there are no Robot available under – EXECUTION TARGET >> Specific Robot tab , while I have created a Robot of type Studio and Local Robot tray is also connected to cloud.I have attached the screen shots.


Please help!

@Jyotirmoy77 Yes, You need to Create Separate Robots for Development, i.e Studio and separate robots for Deployment i.e Unattended or Attended. If you are just testing the process you can Convert the Robot Type to Unattended again and the Robot Should be available.

Thankyou @supermanPunch for your relpy.
When I am changing my Robot Type to >>Unattended ,the robot tray is showing status “Connnected ,Unlicenced”,again .
When I hover my mouse over it it shows “There are no available licences on the server”.
I have attached the screen shot.

@Jyotirmoy77 I don’t Actually know what that problem is but this post seems to have the Solution, Give it a Try :

@supermanPunch
Thank you for your patience .
The problem stil persists

1 Like

When you delete all your machines and Robots, check the License page does it go down to “0 Runtime of 1” for Unattended?

1 Like

Thankyou once agin @codemonkee for replying.
Yes ,when I delete all my standard machines and Robots,License page goes down to “0 Runtime of 1” for Unattended.

1 Like

That is interesting… Not really sure what is going on. Seem a little similar to this other thread I just replied to in which I wasn’t able to replicate the exact issue, but was able to produce the same message.

Try this

  • Create Standard Machine
  • Create Robot
  • Disconnect and reconnect Robot from UiPath Assistant / Agent Desktop

I would expect the Licensing to show 1 Runtimes of 1, and assuming you have the same status message of it not licensing can you show the edit screen from the Machine? It should have bumped up to 1 for a Classic Robot.

1 Like