Desktop Has been disconnected while performing ui action

Hi,

Even though remote desktop has not locked manually or automatically,I’m getting this error while performing some Ui actions in remote desktop. I want to know how to handle this error.
Could anyone please suggest solutions regarding this issue.

Thanks in advance.

1 Like

If I remember correctly, minimizing the RDP window can cause “desktop disconnected” error.

Adrian.

1 Like

Hi adrian,

Thanks for your reply.
In my case RDP window is not minimized. While performing some action in Ui via robot pop message shown with error.

Is that happening all the time and in the same place?

Hi
how are you connecting to RDP?
It happens to me as well cause I am connected through VPN, if VPN drops then error message will appear
hope this will helps you

1 Like

Hi

I’m connecting through desktop only. I have attached the error pop up message in this.
Issue is while Robot is performing some UI actions on my application, I got this error.
Note:- RDP is not disconnected its in active state only…

1 Like

Hi,

Thanks for your reply and sorry for late response.
Its not happening all the time and not in the same place.

1 Like

Hello, did you get a solution to this error?

Try this:

1 Like

Thank you, it’s worth a try, although this happens on a machine that has the process started from Orchestrator (using credentials).

1 Like

I am also getting same error while running process form Orchestrator (using credentials). and getting this error sometime. Please help to resolve this.

Did you find a solution for this??.

Could you give us more errors about the environment, uipath version, os?
@qateam

Desktop has been disconnected while performing UI actions

This occurs when a user is connected with RDP to the Robot machine and the RDP disconnects at some point. We recommend to sign off all the users from the Robot machines before executing a job.

Note: If a RDP connection is started on the robot machine and this machine lose internet connection (even for few seconds), the robot will throw “Desktop has been disconnected…”

To avoid this behavior you have to follow this guide: https://support.smartbear.com/testcomplete/docs/testing-with/running/via-rdp/in-minimized-window.html

Let me know if this works.

Andrei

Hi there,

I found a way to execute a robot on a remote machine without having to remain connected to it through Remote Desktop Connection and I thought I would share. I created a batch file that contains the following:

for /f “skip=1 tokens=3” %%s in (‘query user username’) do (
%windir%\System32\tscon.exe sessionname /dest:console /password:password
)
exit

This disconnects the user from the remote machine but doesn’t lock the machine, which allows programs, including the robot, to continue to run. The batch file must be run as administrator, after the robot is started. These links provide more information: here and here.

It goes without saying this is far from an ideal solution, so tread carefully.

12 Likes

Hello Badita,

I am facing the same above mentioned issue all the time and in the same place.

I cannot perform a click action on a particular place all the time when minimizing the RDP it works perfectly fine when I see it.

I have followed all the steps, created the Remote suppress when minimized and set it value to 2 but even after it is not working.

Can you suggest me any best solution for this.

Regards,
Raviteja.

hi, have you solved this problem now? I met the problem again and again.

Hi! I’m facing the same problem right now, I’m working with Citrix. My artifact works with images, it’s developed on my computer and opens the virtual machine through Citrix.

If anyone know how to solve this issue or has solved this issue before, please tell me! It would really appreciate it.

Regards,

Its happening in same place for me.Any fix

[Error] Desktop Has been disconnected while performing ui action.
Facing same error while triggering the bot from Orchestrator. Any fixes or updates ?