Bot Running in a RemoteMachine via Orchestrator Scheduler and getting Desktop Disconnect Error

robot
rdp
error

#1

Bot Running in a RemoteMachine via Orchestrator Scheduler and getting Desktop Disconnect Error

Its a daily scheduler run at 4:00 AM EST

Exception Details: UiPath.Core.ElementOperationException: Desktop has been disconnected while performing UI actions

Sporadically, we gets this error , but not on daily, i have
“LoginToConsole”: true, and its work

i tried with “LoginToConsole”: false, but from Orchestrator not able to run the job getting error with Session Terminated


#2

Hi,
From my experience, “Desktop has been disconnected…” usually happened when you minimized or closed your RDP window while it is running. Since it does this when you minimize, you will want to change windows without minimizing the RDP window.


#3

well, i run with UnAttended, i don’t login to RDP, as mentioned i have scheduled the bot to run on RDP machine morning every day 3:30 AM

i have maximized the application , and i send out error screen shot to my email, i could see the Applicaiton Page in maximized


#4

Having the exact same issue.
Any solution?


#5

Hi Jane,

Have you tried the suggestions from here?


Orchestrator Process Logout/Login
#6

In my experience you get this error also in cases where the application window the robot is trying to manipulate, is for some reason moved partially outside the desktop. Or in cases where an application has a window within a window and the inner window is not fully visible to the robot.

For example we have this one application where the windows inside the app’s main frame window randomly move and are not fully visible. The robot must always try to move the inner windows to the center of the main frame window before it tries to do some UI activities on the inner window.

One special case where you might also get this error is that the automated app needs for example a Full HD resolution for operation, but when the robot is launched unattended, it gets a lower resolution. I was able to fix this kind of issue with Launch Workflow Interactive activity and by increasing the memory of the system’s graphics card.

I hope this explanation isn’t too unclear…


#7

Thanks for sharing! Your explanation is clear :slight_smile:


#8

@esa.andsten to avoid resolution problems you can set the robot resolution from uipath.settings. The machine’s display resolution width and height. This option is set to 0 be default, which means that it automatically retrieves and uses the detected resolution width. You can use a custom value, as long as it is supported by the workstation.

Check this KB as well: https://www.uipath.com/kb-articles/resolution-considerents


#9

Thanks, I’m aware of that but that doesn’t help if there’s so little memory reserved for the graphics card that higher resolution just isn’t possible to achieve. In our environment the default graphics memory size in virtual servers is only 4 MB!


#10

Hi Ovi, thanks for response.

I use RPD on the server through orchestrator, not open and minimize it, but I also added Terminal Server Client -RemoteDesktop_SuppressWhenMinimized to 2. This problem happened once in a while, like ~5%.
However, I didn’t do the ‘/f “skip=1 tokens=3” %%s’ because never heard of anyone else using this way and it work.


#11

Hi Andrei, thanks.

Yes, I already set the resolution in uipath.setting to be the same as how workstation ran in the background.


#12

Jane, since your initial post is from a few months ago, did you manage to solve it?


#13

I tryied all this nothing worked. But found out the problem happen when i used “send hotkey” instead i’m using “type into”. i cannot tell why maybe specialkeys error.

Worked for me, hope it will work for you too :slight_smile:


#14

Ovi, Nope, but it’s once in a while so I can live with it.

In my case, I use only ONE user for each RDP. Also, RDPs are sitting on the server that shouldn’t lose internet connection. The resolution is also set to match the machine.