Wait for form task and resume - process don't resumes when task completed

Good afternoon, I’m not sure if this is the “normal” behavior or if I’m having an error/doing something wrong. I’m testing for first time the Action Center task options and I’m not sure if I’m configuring it correctly, I followed youtube tutorials: How to use UiPath Action Center - Beginner Tutorial, Part 1 of 2 - YouTube and How to use UiPath Action Center - Beginner Tutorial, Part 2 of 2 - YouTube
That are really good and easy to follow, but I have a doubt/issue that is not solved on it.

Once my tasks are approved, if I’m launching it from Studio I can click on “Resume” and the process follows and ends correctly but, if we use the Tasks option of the Action Center to interact with robots, it’s not to have something manual like this, on a real situation, I can’t ask to all people on my company to mail to start their processes from Studio, mail me when their complete their tasks and resume manually their process, it have NO SENSE. What we want is that processes are launched by theyself (with time triggers for example) or launched by users from Assistant and, after they complete their tasks, the process follows without any additional intervention…so I tried to launch the process on “Run” mode and since Assistant but, for both, the resume is not done, additionally, when I launch it from Assistant, the process is closed when it reaches the “Wait for form task and resume” activity and this is impossible to retake the process after the task completed. I suposed that this is the objective of step “Wait for form task AND RESUME” → so why the “resume” is not performed after the task is approved? Is it normal or we must do something special to able it to work?? :woozy_face:

This is my test process:

Create Form Task arguments:

My WF variables:

I’ve tried task approval from web and from mobile app. I’ve tried without assign task activity assigning the task manually. I’ve also tried to run the process from an unattended robot but with unattended it directly never start. I don’t know what else I can try… :confounded:

1 Like

Hello @Airun!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly
Forum_Staff

Finally it work for me, it seems it was due to the licenses configuration we had for users/machines/robots…not sure at all what combinations are ok and what combinations not.

Hi @Airun ,

Please note that action center process cant be run from uipath assistant. Its mere purpose is to have an effecient human-robot collaboration in an unattended way.

So, while developing to test, it can be directly run from studio and the have to be manually resumed once task is completed in action center.

However, for it to resume execution on its own once task is completed, it has to be run from orchestrator jobs section.

Hope this helps.

Regards
Sonali