V2018.3 UiPath Community Edition release

It’s here, it’s big, and it’s what you’ve been waiting for! UiPath v2018.3, Community Edition, is now available!

Check out Release Notes for new features and improvements:

Install & Update

If you already have the community edition installed, Studio and Robot are to be updated automatically to 2018.3. If you are on the Stable channel, just restart it and you’re good to go. If you’re on the beta channel, chances are you already have it. Hats off, we thank you for being a beta tester! Orchestrator Community Edition has been updated already.
If you don’t have the community edition already, get it while it’s hot, from here. For now, only the UiPath.UIAutomation.Activities and UiPath.System.Activities packs are pushed to the official feed. Please add the Beta feed in Package Manager https://www.myget.org/F/uipath in order to get access to all the activities packs. Remember to check the Include Prerelease checkbox.

The user guides are also updated but keep in mind to change the version from the drop-down list to display v2018.3. You are more than welcomed to provide any feedback to our documentation, via Suggest Edits.

We’re still cooking some changes so expect another stable version soon. Until then, here is a list of known issues:

  • The Chrome extension stops working if you execute processes based on workflows which contain the Attach Browser activity. This only occurs after several successful executions, and for processes that had been started from Orchestrator exclusively. Take into account that closing Google Chrome after the extension stops working can be used as a workaround.
  • An error message is displayed if you search for an activity and add it multiple times in your workflow by double-clicking it.
  • When you export a workflow that contains a GenericValue variable type, the resulted workflow has validation errors as the used variables weren't set as arguments.
  • Generating a selector from a Firefox or Chrome page takes more time than before when using UI Explorer outside of a workflow.
  • While recording in native Windows applications, highlighting elements and clicking buttons does not work properly.
  • When migrating a project by opening it in Studio 18.3 the Core package is split into the System and UIAutomation packages. In the Dependencies panel, these two packages are marked as 18.3, which is an incomplete version, as it lacks the Patch number.
  • Events monitored are not detected when using Click Trigger and Key Press Trigger activities in Windows Presentation Foundation (WPF) applications.
  • Only .xaml and project.json files can be checked out in TFS in Studio. As a workaround, you can edit them in Windows.
  • Some fields in the Filter Wizard of the Filter Datable activity are not yet localized in Japanese.
  • Schedules with non-working days restrictions do not trigger correctly if the timezone defined at tenant level is modified after creating the schedule.

As usual, your feedback is more than welcomed and appreciated. The entire product team is watching the 18_3 tag to see what you think about v2018.3.

The UiPath Product Team is humble to have such a great community. We are proud of how it shaped our product along the years, so please continue to post back your issues, thoughts, pain-points, questions, and any other feedback.

Troubleshooting Guide:

https://forum.uipath.com/t/v2018-3-uipath-community-edition-troubleshooting-guide/68329

14 Likes

Super Excited!

That is great, excitement gets to a level up with every release!

1 Like

Great news, @ovi Like others, pretty excited about the new version, curious about all the new features/improvements that have been added, and glad to have been and be a part of this community. :slight_smile:

1 Like

@siddharth I hope you enjoy the new features. Let us know what you think, i’m Really curious to get your thoughts on this release

1 Like

My favorite thing is looking so nice and appearance is pretty good.

Nice Option

image

Regards
Balamurugan.S

1 Like

Excited:heart_eyes::heart_eyes:@ovi

1 Like

Looks really good, look forward to more such serious upgrades… However, projects that have been opened in 2018.3 once and saved and run are not opening properly in older versions of Studio. Hope we are not the only ones facing this problem.

We don’t have backwards compatibility. That is exactly what you have described: develop a process in 18.3 and open in in older Studio versions. The latest release has new features and some changes that older versions might be incompatible with (for example the core activities decoupling). That’s we don’t support backwards compatibiiity and we don’t consider it as a best practice.

Hello ovi,

i really like the new release. I am really curious about the Java Activites Pack and wanted to ask if the mentioned Example of Using The Java Activities Pack (https://activities.uipath.com/lang-de/docs/about-the-java-activities-pack#section-example-of-using-the-java-activities-pack) is already available and I just can’t find it or if it’s still in production.

Thanks for your answer in advance.

If anyone else has first experiences with the Package let me know :wink:

The java activities pack is still in beta. You can access it like this:

Hi, thanks for your fast answer. Unfortunately your feedback doesnt answer my original question, which was not that clearly formulated. Sorry… I found the Java Activites Pack and also tried already implementing a few things. However, on the posted website https://activities.uipath.com/lang-de/docs/about-the-java-activities-pack#section-example-of-using-the-java-activities-pack there is also mentioned that there is an example on how to use those activities. I can’t find this example and was wondering if it’s me not finding it or if the example isn’t out there yet.

Thanks again for your support.

True. Thats good. I however didnt create the workflow in 2018.3… I just happened to open it in 2018.3 once, and now it is corrupt, not sure if there is an easier way to recover it, other than having to recreate it.

Someone on my team experienced something similar. He used 2018.3 to open a workflow that had been created in 2018.2, and then other users who were still on 2018.2 were no longer able to open/run that workflow. In our case, we were able to recover the workflow by opening it in 2018.3 and deleting all of the For Each and For Each Row activities. 2018.3 adds an Index property that 2018.2 was not able to reinterpret, so removing those in 2018.3 and then reopening and re-adding those activities in 2018.2 fixed it for us.

1 Like

if you didn`t use any core activities new in 2018.3 just deleting project json, will open ok in 2018.2
but, if you did use them, you ll need to manually edit the xaml in a text editor as explaind in the upper post.
we don t offer forward compatibility unfortunatelly

It sounds like what rahultyagi and I are talking about is a little different than what you and ovi are addressing, though. Neither of us added any new activities in 2018.3, we just looked at old workflows in 2018.3. My guess is that rahultyagi’s workflow also included a For Each or For Each Row activity that was automatically updated with the Index property when he opened it in 2018.3.

Why "Community Edition " was emphasized?
Are Community Edition 2018.3 and Enterprise version 2018.3 different?
If so, I’d like to know the different points and the release date of Enterprise version 2018.3.

that is correct… and I suspect there could be some more activities other than foreach that would have the same issue.