Issues with Studio version 2018.3.*

Scenario:UiPath Studio, Community Edition Version 2018.2.3 automatically updated to UiPath Studio 2018.3.0 and now 2018.3.1. After the update my project is broken and cannot communicate with Chrome

Steps to reproduce:Install UiPath Studio Community Edition 2018.2.3, create a project that interacts with chrome just fine. Let UiPath Studio Community Edition automatically update to version 2018.3.## and the interaction with Chrome is broken.

Current Behavior:

  1. Activities that used to work now throw System Error: Cannot communicate with the browser, please check the UiPath extension.
  2. I can no longer select elements from a page in Chrome, only the whole page can be selected.
  3. I have tried multiple things to try and resolve this:
    a. Removed and reinstalled the extension. Note: after removing, trying to re-install from Studio doesn’t work, it says it’s already installed. I re-installed from the url. same result.
    b. Uninstalled and Reinstalled Chrome, reinstalled the extension, same result.
    c. Checked to make sure ChromeNativeMessaging is running - it is
    d. Tried installing the latest version of Chrome then installing the extension, same result
    e. Reverted back to the old version of chrome that was previously working, same result
    f. Installed old version of Studio - Test project works! As soon as I open my real project, Studio updates automatically and the problem comes back.

Note: I have a licensed version of Enterprise Studio on another machine and the auto update doesn’t happen. I also have Community Edition installed on another machine and it’s not updating automatically either, those machines are fine, this is only happening on one machine.

If anyone has been able to resolve this issue, please help! Thank you!

Expected Behavior: After the update, everything that was working before the update still works OR have the ability not to update if it is going to break my project.

Studio/Robot/Orchestrator Version:

Last stable behavior: Interaction with Chrome worked fine.
Last stable version: Studio 2018.2.3
OS Version: Windows 7
Others if Relevant: (workflow, logs, .net version, service pack, etc):

I have a similar issue I just installed again the chrome extension and is working fine again

Reinstall the Uipath extension. After reinstalling, goto Chrome settings, extensions and enable the extension.

Thanks for the comment Vivek, but that is the very first thing I tried. I wish it was something as simple as that. I have tried every suggestion I have been able to find on the Community Forum and Extension Trouble shooting guides. I think it would work if I could install the extension through Studio, but the problem is Studio thinks it’s already installed.

Hi @jdbson

Could you try to kill all Chrome processes and then try to install the extension?

I have the same issue with Chrome and Firefox after the updates (1. I can no longer select elements from a page in Chrome, only the whole page can be selected). Unfortunately, nothing from this topic has helped me. Sometimes the issue disappears for a while, but then it pops up again. I have noticed that the robot can stuck in some selector and when I’ trying to repair it via the “repair” or “indicate” options, the whole screen is indicated instead of a separate element. Only repair of this selector by hand can help sometimes. I never had such an issue before version 2018.3.*