Usual Orchestrator errors (FAQ) - Troubleshooting

This is a list of errors that usually occur in Orchestrator and cause the Robot to not start a job. These errors can be found in the Jobs page, in the Job Details window.

No robot available for user X

This error is displayed when the Robot provisioned on Orchestrator has a username does not coincide with the Robot machine’s username.

Permission missing: Launcher

This error is received in the following scenario:

  • robot is connected to orchestrator with user “abc”
  • on the robot machine you try to start robot (from tray or studio) with user “admin”

Note: some of our users get confused with licensing (e.g. used a community license). If you encounter the error and you are 100% sure that the user from your machine match with the user declared in Orchestrator than use regutil to deactivate the robot license and reconnect to Orchestrator (keep in mind that a SVC restart is required, more details about regutil tool you can find here: Regutil Command Descriptions)

Logon failure: unknown user name or bad password

The username or password is incorrect. If your Robot username is in a domain please write it in the “domain\username” format.

Executor start process failed, reason System.UnauthorizedAccessException: Access is denied.

Password is not provided (edit robot → username and password).

Permission missing: Remote Execution

This error is displayed when you are trying to run a process on a Robot without a license or with a Front Office license.

Executor start process failed, reason A specified logon session does not exist. It may already have been terminated

This error is displayed in the following cases:

  1. The Robot cannot create a logon session at that moment (the error is displayed every time you try to start the Robot). You are connected over RDP to a Robot machine with a different username (e.g. a Robot has the X - admin and you are connected over RDP with the Y username). To avoid this error, sign out all the RDP connections on the Robot machine.

  2. When the error is displayed randomly (sometimes it works sometimes it doesn’t), make sure that the Robot machine has enough resources (e.g. CPU, memory). Try to connect using mstsc and see how long it takes. The Robot has a 60 seconds timeout period for an RDP connection. If this time passes, the error is displayed. (check this guide Config RDP timeout to create user session)

An existing connection was forcibly closed by the remote host Ooops! We’re sorry! It seems Orchestrator is down. Some of the possible causes are:

  • The server was restarted from Internet Information Services (IIS)
  • The server was shut down
  • A clumsy new colleague unplugged your server

Value cannot be null

Usually happens when you start and terminate a job (very fast) from Orchestrator, while the process is still downloading on the Robot machine.

Job not found

Usually, this error occurs when you have a scheduled job with the Terminate After option and the connection between the Robot and Orchestrator is lost. The job is executed but the terminate action does not find the job to stop. You can check the logs (Orchestrator or Robot) to make sure that the job has been executed.

The handle is invalid

This error is displayed in the following cases:

  1. This is displayed only for workflows that contain UI Automation. It usually occurs when an RDP connection already exists in the background (minimized), such as mstsc in the taskbar.
  2. Rarely - Windows issue. Google search for this error, there are many windows users that are complaining.

An attempt was made to reference a token that does not exist

This error is under investigation. At this moment we know that is an error from windows, you can check their solution here:

In order to give a proper answer we need the .etl file from the robot machine that throw this error. Please enable enableLowLevel tracing.

Desktop has been disconnected while performing UI actions

This occurs when a user is connected with RDP to the Robot machine and the RDP disconnects at some point. We recommend to sign off all the users from the Robot machines before executing a job.

Note: If a RDP connection is started on the robot machine and this machine lose internet connection (even for few seconds), the robot will throw “Desktop has been disconnected…”

To avoid this behavior you have to follow this guide: Running Tests in Minimized Remote Desktop Windows | TestComplete Documentation

A device attached to the system is not functioning.

This error is not related with our product (we encounter this error in testing without UiPath installed on the machine). Microsoft explanation here: Error Message: | Microsoft Learn
“An attached device is not working for one of these reasons: (1) it is switched off, or connected improperly; (2) the floppy disk and drive types are incompatible; (3) the floppy disk is not properly inserted in the drive; (4) the drive door is open; or (5) the floppy disk is not properly formatted.”

Executor start process failed, reason System.Runtime.InteropServices.COMException (0x800700AA): The requested resource is in use

Usually appears when you use High-Density Robots (server machine with multiple users) and you have the logintoconsole parameter set to true in the UiPath.settings file.

Execution error : System.UnauthorizedAccessException: Access to the path 'C:\ProgramData\UiPath…is denied

This error can occur in the following cases:

  1. When you use High-Density Robots and all the Robots use the same file to write and/or modify. To avoid this generate the file per Robot/user - unique id.

  2. With a single Robot when it does not have write permissions on that folder, or the file has been already created and the Robot cannot edit the file.

Robot already running for user

This is a known issue and it usually occurs when you have overlapping schedules (e.g. 2-3 schedules that are triggered at the same time).

On the Robot: Bad request. & The remote host did not answer in a timely manner.

All users that exist on a machine have to be connected as Robots. If you have only one Robot registered to Orchestrator, for the second Robot the following error is displayed: “No Robot available for that user.” Also, keep in mind that if you use a workstation for your Robots, you cannot run all of them in the same time.

please check this comment

The remote certificate is invalid…

The public key of the certificate is not imported or is not imported in the trusted root certification authorities of the local machine (imported in Current Users). Please check the Orchestrator Installation Guide (link to Orchestrator 2016.2 Documentation) for more details.

General recommendation: Sign out of all RDP sessions before starting a job on a Robot.

Feel free to ask any questions related to faulted jobs on this topic.


Cannot connect to a robot
Orchestrator failed to start jobs
Error when running process from Orchestrator
Can not connect to Orchestrator from environment requiring proxy authentication
Uipath Studio Error: Permission Missing: Launcher
Orchestrator platform (
Issue in scheduling the workflow via Orchestrator
Uipath orchestratror problems
How to run the robot on Orchestrator?
Send mail STMP error
Robot will not Stay Connected to Desktop
Assign Account/Group to folder in Orchestrator: An unknown failure has occurred.(#1000)
Studio vs Back Office Robot
Issue while starting a job from orchestrator
High-density feature not working
Error Seen in Orchestrator Logs regarding Remote Host Disconnect
Disconnection while there was executing a robot
How to Click with KeyModifiers "Ctrl" in background?
UiPath Orchestrator - Permission missing: Remote Execution
Logon failure: unknown user name or bad password in orchestrator
Desktop has been disconnected while performing UI actions - Remote VM Issue
What the solution for job creation issues in Uipath orchestrotor?
Random Desktop has been disconnected while performing UI actions
Permission missing: remote execution
Unattended Robot interaction with different virtual desktops
UiPath on the remote desktop
Unable to publish project from one user in VM
A specified logon session does not exist
UI path throwing an error when we minimise the remote desktop session in which it is running, here i am using desktop recording to record a mail merge action. Please advise?
Uipath Orchestrator Error
Errors in framework download for advanced certification
"An Error has occurred message" trying to provision a new user in Orchestrator
UiPath Robotの接続エラー(Orchestrator CEとの接続)

When one user robot is connected to orchestrator then for 2nd user robot gets error “No robot available for that user”. No jobs scheduled in orchestrator for the 1st user.
If we remove orchestrator configuration settings from 1st user then it works.
Any idea?

Both users should have a robot associated in Orchestrator. If you have only one robot associated in Orchestrator for the 2nd robot you will get the error “No robot available for that user”. Also keep in mind that if you use a workstation for your robots, only one robot can run.


If you get one of the following errors when trying to connect the robot to Orchestrator
- “Bad request”
- “the remote host did not answer in a timely manner”
Please check if there is a proxy server specified in the “LAN settings” of the robot. If yes, try the following:
1. In C:\Program Files (x86)\UiPath Studio\UiRobot.exe.config, add the following section, at the end of the section (in this section, but at the end of it):

.... <> <defaultProxy> <proxy usesystemdefault="true" proxyaddress="http://proxy_server:proxy_port" bypassonlocal="true" /> </defaultProxy> </> </configuration>

2. In C:\Windows\SysWOW64\config\systemprofile\AppData\Roaming\NuGet\NuGet.config (create this file if it doesn’t exist), add the following section, in the <configuration> node:


<add key=“http_proxy” value=“http://proxy_server:proxy_port” />

Don’t forget to restart the UiRobotSvc service after the changes are made.

1. The above only covers the un-authenticated proxy scenario.
2. Regarding Studio, publishing works ok given the proxy is correctly configured in Internet Options

1 Like

Can you assist me with the below error message. I get this when I start the job from the orchestrator.

More Info : I just upgraded the Orchestrator from 2016.1 to 2016.2. I;m able to run the studio and see the logs in the Orchestrator.

I have added my windows credentials(double checked) while registering the robot.The robot machine has an active studio license.

{"message":"NotificationProcessor : failed to start job 88c3606b-24da-47d5-a53d-d2ed448c633c, process cmdArgs_Development, error System.Exception: Permission missing: Remote Execution\r\n at UiPath.Service.Orchestrator.NotificationProcessor.<HandleStartMessage>d__10.MoveNext()","level":"Error","timeStamp":"2017-06-16T08:53:32.0103403-04:00"}

Update : This looks to have been resolved. I was using the High density robots and few days back I have changed the license config file to point to %localappdata% instead of %ProgramData% and it was causing the issue. I reverted back to the ProgramData and it seems to be working now.

1 Like

What is the solution for the below:-
"The requested resource is in use

Usually appears when you use High-Density Robots (server machine with multiple users) and you have the logintoconsole parameter set to true in the UiPath.settings file."

I received “…resource is in use…” the other day as well and have no idea why we are getting this. UiPath.settings has logintoconsole set to false and RDP licensing is active and tested with multiple logon sessions.

I ran one of our jobs received error, then ran a test job and was successful… ran our main job again right after and received error. Job ran perfectly fine this morning :man_shrugging:

It has been pretty random for our environment or so it seems. I’m wondering if it’s how our workflow modules are being called or that shared modules can only be used one at a time. I don’t know!


I tried running it from within Studio to atleast do some testing and got same error. There is one process running on another account on the server and the Interactive has something to do with it. I have confirmed that more than 2 users can log in at same time.

try this

1 Like

In my case, I have figured out that it’s not random. I have also verified logontoconsole is false and that more than 2 users can log in. It only happens when a process is running that uses Launch Workflow Interactive and you try to run another process that uses Launch Workflow Interactive at the same time on another user id. Any process not using that activity to kick off a process runs fine with no issues.

So, it’s only happening with Launch Workflow Interactive when a process using that activity is currently running.

Any ideas what would cause this or if this might be a flaw with UiPath?

I can try further steps to resolve this when I get back into the office on Tuesday. I will also test this error on another server.




From what I remember this error usually occurs when you have a console session open with another user than the one provision as robot in Orchestrator. This include either another Uipath robot or an RDP session.

Do you have any Remote desktop/VMware (like Horizon) session open on the machine when this occurs?

You also mention that logIntoConsole is set to false. Does that both include UiPath settings and Launch interactive workflow checkbox?


It was occurring when a process using Launch Interactive was running (unattended) when I try to run another process that uses it, so it was only letting us run one process that uses it at one time.

I have verified that “LoginToConsole” is checked. Are you saying that we should uncheck that option? I can try that when I get a chance.


I believe you should uncheck it, RDP console session are limited to one as far as i know, if a second interactive workflow with different user is attempting to connect with console, i would say i would make sense that it fail.

To be honest, I would not know if setting it unchecked would be enough, potentially even two interactive session could be problematic.

Let us know if you have the occasion to test.
If still not working i would also try two non interactive session, if still not there would certainly be something wrong with the HDR setup

Good luck



I have tested this with Launch Interactive and LogonToConsole unchecked, which resolved the “resource is in use” error that I was getting.

Thanks @Florent_Salendres for the idea

1 Like

my flow is developed in my VM after installing that bot in Orchestrator successfully,while running that process as a job in orchestrator it throws exception like,
Execution error : System.Exception: The volume does not contain a recognized file system.\r\nPlease make sure that all required file system drivers are loaded and that the volume is not corrupted anyone please give solution…?

And after run that job my VM get closed why…?


As I have described at this topic (Advanced Training(Academy 2) - Assignment 1 - Orchestrator exception - #2 by dntakoulas) I have the robot in my machine connected and running, but I still get a System.UnauthorizedAccessException: Access is denied

It happens every single time and it looks that the robot cannot add items to the queue. Any tips?


Hi Ovidiu. How can I connect the robot to the orchestrator if the PC is behind a authenticated proxy. I’ve done all the things above and from the this guide: Redirecting Robots through a Proxy Server
but I still can’t connect. I’m getting a “502 Bad Gateway” error. I’m really struggling with this problem. Also, my robot needs to send a HTTP Request, but is also not getting the authentication right.


Hi Andrei,

I’m getting the below error when trying to create a process.