Requested resource in use Exception - Orchestrator

I am getting “Requested recource is in use” exception everytime I connect my bot with Orchestrator. Below is full log:

Info : “Executor start process failed, reason System.Runtime.InteropServices.COMException (0x800700AA): The requested resource is in use. (Exception from HRESULT: 0x800700AA)\r\n at UiPath.UiSystemClass.OpenInteractiveWindowsSession(String bstrUser, String bstrPassword, UiOpenSessionFlags nFlags, String bstrApplication, String bstrAppArguments, Int32 nDelayMs, Int32 userToken, UiGenericOptions options)\r\n at UiPath.Core.Setup.OpenInteractiveWindowsSession(String username, String password, OpenSessionFlags flags, String application, String arguments, Int32 userToken, Int32 preferredWidth, Int32 preferredHeight, Int32 preferredDepth)\r\n at UiPath.Service.Impl.Executor.StartProcessInSession(Guid executorInstanceId, String username, String password, OpenSessionInfo sessionInfo, IntPtr userToken)\r\n at UiPath.Service.Impl.Executor.<>c__DisplayClass13_0.<b__0>d.MoveNext()”

1 Like

Hi @shailesh_gohel

Usually appears when you use High-Density Robots (server machine with multiple users) and you have the logintoconsole parameter set to true in the UiPath.settings file.

Do you have the robot on a windows server machine?

4 Likes

Hello @ovi,

I am getting the same error. Using UiPath Community addition and trying to run the Job on https://demo.uipath.com

Robot is created on Windows 10 machine and successfully deployed. Tried with logintoconsole parameter as “True” & “False”.

1 Like

Have you also tried on https://platform.uipath.com/? Just to be sure.

Yes, I have tried on both https://demo.uipath.com/ and https://platform.uipath.com/

Getting same error on both.

Hi,
I don’t see any other option but how about this.
Just stop UiRobot service (all by the same name if available ) from service manager and restart the Service and give a try.

1 Like

Hello @ddpadil,

Also tried that option. Stopped UiRobot Service and checked after restarting it. Still the same behavior.

I also tried Manual and Scheduled execution with Robot Type = Free.

@Andrei_Pop

Try the following:

The error usually appears:

  • hd robots
  • machine is overloaded
  • rdp is not enabled
  • another user use the session

Let me know your findings.

Andrei

3 Likes

One and simple solution that you need to login your orchestrator with your PC/Laptop’s admin user name and password

Hi Andrei,
If i disconnect the machine before starting a job, it is working. What would be the solution for this?
I noticed that, when the first bot completes the run from orchestrator, it is not logging off and we are getting “request is in use” when i run the second bot.

I manually tried to login with second bot’s credentials and i got the below message.

Hi,
I am getting the same error when ever i try connecting to orchestrator. I dont use any remote machine to connect. I have the uipath process in a machine and i connect the robot from the same machine via https://staging.uipath.com. I tried even using platform/demo.uipath.com but same error persists. I even changed loginToConsole tp false. Yet no solution. Can some one please help me?
Thanks in advance.

Hi Sravenco,

Have you tried all the solutions provided by Andrei above?

yes. i tried.

You can also get that error if you are using Launch Workflow Interactive with Logontoconsole checked.

Only other time I’ve seen this is when:

  • Logontoconsole is set to true on the server it’s being run on
  • Server is set for only 2 users max and a 3rd user tried to run a job while 2 are connected
1 Like

Hi,
I am getting the same error when ever i try run the robot using orchestrator. I have Win10 and the latest version of UI Path. And i tried all solutions higher. Help me please!

Screenshot_3Screenshot_7

Hi,
We had this issue and the problem was that the password contained special characters (in Turkish). We solved it by creating a new user with the password containing English characters.
I hope this solves your problem.

2 Likes

thanks for answer!
We solved this problem similarly

as per the discussion i had with UiPath support team there was a mistake on their website regarding this Logontoconsol which need to be false. soon same will be updated on robot guide.

Hi Adrei,

I manage my demo account with https://platform.uipath.com/settings.

My robot installed like this below.


I’m using one machine. Windows10. I installed the studio in my machine. And i connect platform.uipath with same machine.
When i work from below, it works correctly
image
and sends to orchestretor succesfull maessage.


But when the time comes to trigger from platform.uipath.com it gives an error below.

I controlled my remote desktop connection setting, and i saw that it gives permission. By the way it is company computer, if there is any extra point i can give details.

My Machine : TR01BUTN1208
Robot name: hakan
Thanks.

1 Like