Uipath orchestratror problems

. My problem is the following: once I connect the robot with the orchestrator, create the process and start the job the process doesn’t work and gives me the following problem:

Info : "Executor start process failed, reason System.UnauthorizedAccessException: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))\r\n at UiPath.UiSystemClass.OpenInteractiveWindowsSession(String bstrUser, String bstrPassword, UiOpenSessionFlags nFlags, String bstrApplication, String bstrAppArguments, Int32 nDelayMs, Int32 userToken, UiGenericOptions options)\r\n at UiPath.Core.Setup.OpenInteractiveWindowsSession(String username, String password, OpenSessionFlags flags, String application, String arguments, Int32 userToken, Int32 preferredWidth, Int32 preferredHeight, Int32 preferredDepth)\r\n at UiPath.Service.Impl.Executor.StartProcessInSession(Guid executorInstanceId, String username, String password, OpenSessionInfo sessionInfo, IntPtr userToken)\r\n at UiPath.Service.Impl.Executor.<>c__DisplayClass13_0.<<Start>b__0>d.MoveNext()"

How can I manage this problem?
Thanks a lot.
Jacopo

Hi,

Are you able to Remote into the Server using the same user id that is used for the Robot you were using to run the job on? If the user id does not have Remote authorization then that could cause problems.

Probably password is missing or incorrect in provision robots.

I’m using uipath robot installed in my computer from which I start the orchestrator. I’m following the instruction in the course: Orchestrator 2016.2 Training

How can I check the correctness of robots provisioning?

1 Like

Sorry, I mean the user id in the Robot that you provisioned in Orchestrator to run your job.

You can verify if the user id has Administrator or Remote Authorization by going to Control Panel > User Accounts > Manage User Accounts
If you receive a Credential screen, then your user id doesn’t have Admin rights and therefore that might be an issue for logging into your computer from Orchestrator.

There is also info on Troubleshooting here:

Regards

I have the same problem :frowning: I have admin rights and tried it on two computers, but still same problem.
I can start process that is in orchestrator from robot PC, but cannot start it from orchestrator :frowning:

Using Orchestration I’m tried to run the citrix automation process but it has failed and shows error message like:

Execution error : UiPath.Core.ElementOperationException: Timeout reached. —> System.Runtime.InteropServices.COMException: Timeout reached.\r\n at UiPath.UiNodeClass.BringIntoView()\r\n at UiPath.Core.UiElement.BringToForeground()\r\n — End of inner exception stack trace —\r\n at UiPath.Core.Activities.TaskAsyncCodeActivity`1.EndExecute(AsyncCodeActivityContext context, IAsyncResult result)\r\n at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)\r\n at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)"

Anybody knows about this exception please share.

Thanks,
TharmaKS

Does it run successfully when running from Robot machine?
Here is a possible workaround: Cannot schedule the process with Windows task scheduler: Timeout reached

1 Like

Judging by what threw the exception:

It looks like possibly a TypeInto with Activate checkbox or similar activity failure. Weird that this part of the operation would fail, but doesn’t seem Orchestrator related at first glance, as it’s not related to job run per se.
Or I’m wrong of course.

Hi,

When i am trying to run the jobs through orchestrator, I get this error-

Can you guys Please suggest something? @andrzej.kniola @Jishnu_Kumar @Ganga_Bharani

Hi,

Have you changed the LogOn type of UiRobotSvc?
Please check in services if the Uipath robot service is running under local system account.

1 Like

Hey

i’m having the same Error with the Type into activity.

It works fine for a couple of times , and on other times it fails.
Is there a fix for this problem?

"UiPath.Core.ElementOperationException: Timeout reached. —> System.Runtime.InteropServices.COMException: Timeout reached.
at UiPath.UiNodeClass.BringIntoView()
at UiPath.Core.UiElement.BringToForeground()
— End of inner exception stack trace —

And i am 99.99% sure the element exists and is found by the robot

Hi @DS_renewi

Could you give these threads a read?
https://forum.uipath.com/search?q=%22timeout%20reached%22%20status%3Asolved

Also, please remember that it is not reliably possible to run an unattended automation (on a locked screen session) on the Community Edition.

1 Like

Thank you for the respons Loginerror

Unfortunaly it did not help, we tried all sollutions, and the problem is still occurring.
When we monitor the proces, the flow is going perfecly but when using the orchestrator, or minimalising the remote desktop connection, it fails. (but not all the time :expressionless:)

I also have build in a element exist to check if the selector is available, and it returns true

If you have a other solution i am glad to try it.

Thank you

When you click on minimize, you lose the GUI interface of the remote connection. So while monitoring it, you normally don’t want to minimize, however, you can look at the SuppressWhenMinimized registry fix. Here is more info found in a recent post I made: Timeout error whenever Terminal server gets disconnected and another on the fix https://robot.uipath.com/docs/executing-tasks-in-a-minimized-rdp-window

When using Orchestrator, you will first want to make sure “Logontoconsole” is turned off for the robot. You can change this setting while editing the Robot’s settings in Orchestrator. Secondly, you will want to change the resolution settings in the same place (ie 1920 w, 1080 h, 32 depth). The resolution will allow the screen to be ideal size so all your elements will be shown on the screen like when you were developing the project.

If that doesn’t help, then I suggest you use TakeScreenshot and Save Image, so you can see what the screen looks like before the error occurs. - you can see if any weird popups occured or anything else.

Regards.

2 Likes

Hey ClaytonM

We tried the solution that you provied, The adding the registry items did not work, nor the printscreens give strange screenshots. everything seems normal.

Except we are still gettinging the UiPath.UiNodeClass.BringIntoView() exception.:frowning:

Is there another solution that you know? or Someone else?

Hi DS_renewi, were you able to solve the bringtoview() error?