Unable to connect Orchestrator to the VM

robot

#1

Hi All,

UI Path is setup in VM ware. The VM does not have credentials. I can also run the jobs created through UiPath Robot and the connection of UiPath Robot and Orchestrator is also successful. A

Do we need a separate license to run jobs from Orchestrator if we are using community edition?

I am getting the below error while running the job created in orchestrator:

“Executor start process failed, reason System.UnauthorizedAccessException: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))\r\n at UiPath.UiSystemClass.OpenInteractiveWindowsSession(String bstrUser, String bstrPassword, UiOpenSessionFlags nFlags, String bstrApplication, String bstrAppArguments, Int32 nDelayMs, Int32 userToken, UiGenericOptions options)\r\n at UiPath.Core.Setup.OpenInteractiveWindowsSession(String username, String password, OpenSessionFlags flags, String application, String arguments, Int32 userToken, Int32 preferredWidth, Int32 preferredHeight, Int32 preferredDepth)\r\n at UiPath.Service.Impl.Executor.StartProcessInSession(Guid executorInstanceId, String username, String password, SettingsDictionary execSettings, IntPtr userToken)\r\n at UiPath.Service.Impl.Executor.<>c__DisplayClass15_1.<b__0>d.MoveNext()”


#2

Hi @Pranav_Nikam,

I think you are trying to run it from different user account.
Can you try to repair with current user account. May be, it will work for you or repair will set the access right issues at the background.

Regards
Balamurugan


#3

Hi,

I am not sure how to use the repair functionality. Could you please provide the steps in brief.
Also, I am giving the domain name as machine name and username as pranav or admin. I am not giving any password since the vm does not have any.
In both the cases it did not work while creating the bot. Can you provide any details which I should provide for the creation of the robot.


#4

Have you done this ?

Regards
Balamurugan


#5

Hi @balupad14,

The license has expired for sure. But, I tried renewing it. It still did not work out.
I am getting the below information about the license when I ran the command as mentioned in the document that you shared:

C:\Program Files (x86)\UiPath\Studio\UiPath>regutil.exe get-info
License code: 386700039638789990
License status: -116
Device id: AZS4UwUIwpcgyHmY5zWR
Error reading license expire date: -6003, error description: Lookup of tag faile
d
Maintenance expire date: not set
User defined field Attended: not defined
User defined field Unattended: not defined
User defined field Free: not defined
User defined field Dev: not defined
Concurrent: false

Do you have any info as to how renewal of license works?


#6

Hi @Pranav_Nikam,
You can send a mail to support center.

Regards
Balamurugan