UI element is not found when running process though Orchestrator

Hello,

I have an issue running a process from Orchestrator where it does not find a UI element to click it.
It works perfectly when I run the process manually from the Studio.

I have tried the solutions coming from the following posts:

None of those possible solutions helped unfortunately.

The element that I am trying to click on is the pop-up that appears when we’re trying to save a document on Internet Explorer asking if we would like to save the file or open it.


(The image is just an example I’ve found on google)

Thanks,
Marian

Hi @NAyRAM

Please use the click the drop down

And Click the saveas type.

Regards

Hi @NAyRAM,

Are you using attach window/browser activity for pop up screen?

Using this activity helps in identifying window/browser properly and elements inside it.

Regards
Sonali

That is the main issue, the robot clicks it when I run the process through Studio but when I run it through Orchestrator it does not find the element.

I have tried with and without attach window/browser. No success.

Hi @NAyRAM

Try with Element exists for the popup saveAs window.

Regards

Hi @NAyRAM,

Please try following:

  1. use attach browser activity
  2. inside that, first activity as element exists which will find any element on that pop up window
  3. if found, proceed further

And if you see that this behavior is inconsistent and sometimes element is not being found, also include the following:

  1. element exists - wait for ready property as ‘interactive’
  2. element exists in retry scope and exit only when element is found
  3. increase activity timeout as well

Alternatively, you can use find element to find element and save it. Then instead of selector, pass that UiElement in element exists or whichever activity you wanna use that element in.

Hope this helps.

Regards
Sonali

Hi @NAyRAM

Could you provide more details about your environment? Mainly, what type of robot service are you using - the machine robot service of the Enterprise MSI installer or a user robot service of the Community EXE installer?

Hello,

I believe it is Enterprise but I am not entirely sure. Is there a way for me to confirm?

Thanks

Yes, when you go to Home in Studio, all the details will be listed in the bottom left corner:
image

Recently,my studio version with 20.10.2 also have this problem

uiautimation package version=2021.4
open application error:can not find ui element

i will need more details, can you share the xaml? does this happen with any automation? is it browser automation?

after I modify the type from service mode into user mode.
the process run successful.
But I wonder why it worked.

I think this might add to the explanation:

1 Like