Getting error while running the process via Orchestrator but not via Uipath Studio

Hello Everyone,

When I am running the process using UI Path Studio then the activities are working properly but while running the process via Orchestrator it is showing selector not found.
i have updated the selector and taken stable attributes only.

Please help!

Thanks,
Sweety

Actually that should work as it works from studio
Kindly check whether the right robot is run from orchestrator once
Cheers @Jainsweety

@Palaniyappan Yes i have checked i am using right robot for correct remote desktop machine.

@Jainsweety

try to use Takescreenshot.xaml activity whenever there is an error.

also if you check logs then you might get some idea about where exactly the problem is?

Regards
Ajay

@Ajju I have checked the logs in that when i am renaming the excel sheet , at that place i ma getting error says selector not found .i also updated the selector and used only stable attributes.
About Takescreenshot activity how and where to use in my process?

@Jainsweety

are you using selectors to rename the Sheet ?

Takescreenshot.xaml is already added in Re-frame work just you need to call it where ever your handling Exceptions

@Ajju here is the snip where i am getting error while running from orchestrator.

@Jainsweety

Have you used click activity or Click before type property ?

if click is happening on the Sheet name then use the Type into Activity in simulate mode

@Ajju

Tried both the options still not working.

@Jainsweety

then go for Hotkeys

inside excel scope, use following hot keys with some delay like 1 sec or 2 sec

  1. Alt+h
  2. Alt+o
  3. Alt+r

then use type into activity, but don’t mention any selector for type into activity
After type into activity use Enter hotkey

if you refer the below workflow

RenameExcelSheet_UsingHotKeys.xaml (9.1 KB)

@Ajju

Thank you for your help but this solution i have already used to select the Sheet tab. hor.
Then i used Type Into activity : Sheet1 without any selector.
Now this is working.

But one more thing i wanted to ask, this is resolved but there are many activities which are working fine in uipath studio but when i am running from orchestrator it is showing UI element not found,
So is there any best practice we should follow while running the process via orchestrator.

Thanks

@Jainsweety

As per my understanding it is not the best way to automate excel operation using ui automations.

Because you will face many issues like above… Sometome uipath not able to find the element.

Uipath support such kind of features so you can use vb scripts or java scripts to do some operations with excel

Such case you can use your coding skils by injecting other languages programs to uipath.

If your any issue related to ui automations , or if some where your not finding any work arounds then you can post it to forum any one will help.

Best regards
Ajay

Hello,

Is there any solution to this below issue:
Error {“message”:"Type Into ‘Edit-Contact list’: Cannot find the UI element corresponding to this selector: "

This is coming when i am running from Orchestrator otherwise it is working.
so is there any input you have about selector that when we run from Orchestrator,
which selector’s attribute we should use?

Hi,

Could you tell me if you are running robot from orchestrator is it the same machine you used and it was working ?
If this is different machine maybe there is someting hidden in the selector that is unique for machine

@rado,

Hi,

when i am running from UI path studio(installed in virtual machine) “type into” activity is working but when i am trying to run from orchestrator(from my local machine) it is showing above error.

I mean if you run robot from UiPath Studio or Orchestrator does it work on the same machine ?

Question is if you have made changes in UiPath Studio, have you publish those changes and update package in Orchestrator ? Maybe you have different package used in orchestrator and it is not working correctly.

@rado

Machine is same.
when i made changes i always publish and update on orchestrator then i run from there.

Ok,

I checked your selector and i have question, why have you omited Title of window, can you turn it on and check ?

@rado

I tried but still not working.
Error {“message”:"Type Into ‘Edit-Contact list’: Cannot find the UI element corresponding to this selector: "

Is it whole error message ? If so then we are having solution because selector is empty. Are you using some kind of variable to as a selector ? Could you please share properties of type into activity ?