Stuck on Send SMTP mail Message Activity

I use RE framework for development and I tired to throw business rule exception on “Process.xml” and handling the business rule exception and sending email though smtp activites. I using debug mode on studio PC, it work without any issues.

However, I deploy my package to attended robot, but it always stuck on send smtp email with no error and log. I tried to ping the email server, it have feedback.

I tried 1.10.5 & 1.9.5 UiPath.MAIL.Activities, but the issues still happen.


You didn’t provide Logon details in SMTP activity.

Hi lakshman, SMTP server doesn’t require authentication


It requires authentication details. Did it work on any other system without Logon details ?

but I have sent mail message without logon details on UiPath studio.


As pery knowledge it requires authentication details. If you have logon details then provide it and then check once.

I don’t have any logon details. Could I invoke vba code to send smtp email?.


Have a look below thread.

Is the Windows user login same with both the attended and unattended robot and with the correct credentials?


If credentials are not required for your server to send an email then check whether the BOT machine is behind any Firewall ? Can you please check with your IT support Team.

We also confirmed the behavior, although it appears random. Unattended robots always work correctly, but for Attended robots sometimes the activity itself gets stuck → to the point that even it’s built-in timeout fails to trigger.

We’ve fixed this with restarting the machines where the attended robots are installed.