AuthenticationChallenge exception when using Send SMTP Mail Message


#1

Hi,

I’ve just started evaluating UIPath for use within our organisation and thought i would start off with something simple. I’m attempting to build a simple robot to iterate over all emails within a particular gmail label and forward them on to another mailbox.

I’m able to iterate over the emails and display details about each email, but i receive an error when sending an email using our SMTP server. Our SMTP server does not require authentication.

The error i receive is as follows;
image

Am i doing something wrong, or is there another method to set the “Send SMTP Mail Message” activity to not require authentication?


#2

Can you share the properties configured for this activity and the concerned xaml


#3

I’ve included the properties below, unfortunately i need to mask our server, to and from addresses.

Main.xaml (6.6 KB)


#4

you have to mention the port, logon email and password also in SMTP Send Mail Message. Try and Check, it should work as everything is fine.


#5

Hi @cconnors,

Refer below url to configure the mail before using in uipath.

https://www.uipath.com/kb-articles/enabling-email-activities-for-gmail

Then try.

After configuration you ll get the password for using in uipath SMTP send mail message activity you need to give below properties.

Email -> body,subject
Host->port and server
Login-> mail id and password->generated password
If you are using html structure check isbodyashtml property.

Regards,
Arivu


#6

Hi Arivu and Manish,

The issue is, our internal SMTP server does not require authentication.


#7

I too have the same issue, our internal SMP server also working without any authentication.

But UiPath force for authentication and end up in error.

Please refer to the similar kind of post that I created, How to send e-mail using UiPath (SMTP) without authentication


#8

Hi All,

Our IT team have now enabled the ability to use Gmail’s SMTP server from within our network.

Thanks for all your suggestions.


#9

For anyone still dealing with this, refer to Configure SMTP for Anonymous mail