Attended Bot Stuck After Sending Email

Continuing the discussion from Robot will not finish process. Keeps running after ran entire flow:

I run my Background Process bot from Assistant, at the end state, the bot will send three emails via SMTP to users. One of them was managed to be sent (and sometimes none of them). However, in debug mode, the workflow successfully ends.

I’ve also followed the below solution (to restart it) but still didn’t work.

Below is the used input argument fields for the SMPT activity:

  1. Attachments = filepath
  2. Body
  3. Subject
  4. Port
  5. Server
  6. Cc
  7. To
  8. From
  9. SecureConnection = None
  10. IsBodyHtml = untick

Below is the Send Email workflow’s outline:

I don’t think any of those activities require UI Interaction. Is anyone facing the similar issue?

Hello @azeem_rosli ,

It’s strange as its working ind debug and failing in the run mode. As you mentioned you already tried restarting the machine. Could you try connecting the bots again to the machine. Then try publishing a new copy of package. Also make sure all the packages are updated.

Thanks @Rahul_Unnikrishnan for the response. However, no luck. It seems that SMTP activities and Attended Bot don’t go well together (at least for me). Whereas, I have an unattended bot and it can send email via SMTP activities. Might use that unattended bot instead.