Open browser : Cannot communicate with Internet Explorer browser

I am trying to use open browser activity in uipath , but it is giving the following error :
Main has thrown an exception

Message: Cannot communicate with Internet Explorer browser.

Source: Open browser

Exception Type: BrowserOperationException

UiPath.Core.BrowserOperationException: Cannot communicate with Internet Explorer browser. —> System.Runtime.InteropServices.COMException: Cannot communicate with Internet Explorer browser.
at UiPath.UiBrowserClass.Open(String bstrURL, UiBrowserFlags flag)
at UiPath.Core.Browser.Open(String url, Boolean privateSession, Boolean headlessSession, Boolean defaultSession)
— End of inner exception stack trace —
at UiPath.Core.Activities.ScopeActivity.EndExecute(NativeActivityContext context, IAsyncResult result)
at UiPath.Core.Activities.AsyncNativeActivity.BookmarkResumptionCallback(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkCallbackWrapper.Invoke(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

And if i select chrome as browser then also it gives me same error with message please check UiPath Extension.

Could anyone please help for the same.

1 Like


Please check the version of uistudio. As UiStudio 2016.1.5999 has this issue. Please try to upgrade to newer version.

Or else you can try the below steps

Here are the steps to follow to fix the communication with IE browser:
• open an elevated command line (cmd.exe with admin rights)
• then type regsvr32 oleacc.dll

Thank You :slight_smile:


Hi @jyoti.bijlani2009

@nikitha.hanumanthara i don’t think so it is a uipath version issues. it is generally occurs due to IE browsers caching and DNS server issues so we can reset IE settings by using this way.

It works mostly.



@aksh1yadav and @nikitha.hanumanthara I don’t have admin rights. Is thereany other way to resolve this issue?

1 Like

hi @vrushaliNN

Please raise a ticket to your IT helpdesk and tell them to do this steps with admin access.


1 Like

We had this issue too, but hasn’t solved by “regsvr32 oleacc.dll” and the setting in the “Internet Explorer Automation Troubleshooting” page.

Our solution is:
Add the website that you can’t open to trust list.


Hi @tomy

I am not sure this will resolve issues because it is IE DNS thing. But the same thing i have observed even with registry fix it was not working so i have tried with private session as well and that time it was working but may be useful.

Thanks for sharing :slight_smile: :+1:


1 Like

Hi Can you please share how you tried with private session.
I have tried registry fix, it is not working for me.



We have experienced this issue now a few times on our VDI’s.
Rebooting the VDI resolves the issue for us.
But it does not explain why it is necessary or what has happened.

We would like to understand what this error is.

1 Like

I am also facing exact same issue for Firefox. Is there any final working solution for fixing this issue for firefox?
OpenBrowser is working fine for Chrome, but the issue with Chrome is I am not able to use any other Get Full text or OCR Text or any screen scraping things. Because it is giving UI element not found. Which is also strange on Chrome (where as all screen scrape things are working fine in Firefox).

If some give fix for for any of these issues that would be really great…

Hi Ravi,

It should work with Firefox 32-bit. It is a known issue for the 64-bit version.
More details here:

Yup. It is working fine in 32bit version. I saw that in other thread. Thanks.

Hi, my friends experience the same issue, do you have any updates on this?

I have the same problem “cannot communicate with Internet explorer” and tried allowing webpages, using the “regsvr32 oleacc.dll” command in an elevated command line and everything else I could find by googling.

1 Like

Solved by adding the webpage to trust list in Internet Setting.


who’d ever thought :no_mouth:

I am trying to use open browser activity in uipath , but it is giving the following error :
I already try all the above


I am facing the same problem, this error just popped up out of the blue. The same workflow was working on Friday and now I am seeing the error.

The solution marked here doesn’t add up, are we supposed to add every website we access to trusted site list. Even “” does not work in Open Browser activity.

I have tried both the steps from Internet Explorer x64 Troubleshooting but still didn’t fix my issue.

Restarted my machine, cleared cache and temp files.

I tested on my laptop and the open browser works as expected. The only difference would be to the community Vs Enterprise and it is not working on the desktop that has Enterprise.

Any help would be greatly appreciated!

the IE version is exactly the same?

Hi @Gabriel_Tatu, Thank you for checking, I found the resolution in my case:

The IE version was the same. The issue was caused due to a system update patch that ran over the weekend. I find out that there was a system update that had happened which disrupted the IE version. Our System admin found a Skype update that was pushed and that was prohibiting the communication to the browser, once the regedit entry for the Skype update was deleted everything was back to normal.

Thanks again.