Can't communicate with internet explorer


I am getting the error while navigate URL to process next item in assignment 2(Academy 2).
After completing the first work item, getting the error as shown below screen shot.

Tried the steps explained in the article, executed the command but still getting the same error.

@ovi @andrzej.kniola @ddpadil please help me on this.



Could you give a try following this?


I know it sounds pretty dumb, but have you tried to reboot the machine?

From what I experienced closing all browser windows and reopening after executing the cmd was even enough :slight_smile:

Yeah but sometime the dll fixing also is not able to resolve this issue as i heard from many others.


I did a little digging on this. It’s a known issue, in progress to be fixed. I’ll let you know when it’s done.
In the meantime, the known workarounds are the ones provided by most of you.

Issue ID: 6430

Hi All,

I have registered required dll (regsvr32.exe oleacc.dll) but still getting the same error.
Please help.

Main has thrown an exception

Source: Open browser

Message: Cannot communicate with Internet Explorer browser.

Exception Type: BrowserOperationException

UiPath.Core.BrowserOperationException: Cannot communicate with Internet Explorer browser. —> System.Runtime.InteropServices.COMException: Cannot communicate with Internet Explorer browser.
** at UiPath.UiBrowserClass.Open(String bstrURL, UiBrowserFlags flag)**
** at UiPath.Core.Browser.Open(String url, Boolean privateSession, Boolean headlessSession, Boolean defaultSession)**
** — End of inner exception stack trace —**
** at UiPath.Core.Activities.ScopeActivity.EndExecute(NativeActivityContext context, IAsyncResult result)**
** at UiPath.Core.Activities.AsyncNativeActivity.BookmarkResumptionCallback(NativeActivityContext context, Bookmark bookmark, Object value)**
** at System.Activities.Runtime.BookmarkCallbackWrapper.Invoke(NativeActivityContext context, Bookmark bookmark, Object value)**
** at System.Activities.Runtime.BookmarkWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)**

For me Allow Active Scripting is Enabled then also getting same error. Please suggest

Hi Team,

Could someone Please help all if knows the correct solution for “Cannot communicate with the Internet Explorer Browser” how to rectify it.

Thanks in advance…

Any solution for this yet?

I have had this issue also. I found a possible work around for the people that are allowed by their security groups.

I start UIPath Studio as an administrator.

I currently use community edition 2018.3 on a windows 10 machine with Skype. I have looked into all the possible fixes that have been mentioned in the different paths and this was the one that worked for me.

I had The same issue alter upgrade to Windows10 on virtual machine. In my case…simple setting IE as default browser instead of Egde helped :slight_smile: