Get item details workflow in assignment1?


#1

Hi there,

I am now in the last phase of the workflow: process.
However, I am confused. It said that we need to Invoke the System1_NavigateTo_WIDetails workflow, but how come the screen shot has different name of XAML:

Also, I think that there is inconsistency in their information of passing argument?
Thank you for your feedback!


#2

You can use the workflows that your created in your own order they have given the structure what It should look like and your program should run without error


#3

Hi Nazarius, have you solved this problem?


#4

@Ilemon,

Yes, I did not follow the walkthrough to make this workflow. This is my process:


#5

Thanks Nazarius, I’m struggling with “SHA1Online_GetHashCode”, since it said you should do necessary steps yourself, actually I am quite confused about this part.


#6

You need to paste your key ClientID-Client Name-Client Country in SHA1-Online and get the hash code from there -


#7

The “Process.xaml” cant be involked.


#8

Please see the Get Transaction Data workflow, are you getting WI_list from there?


#9

Hi prankurjoshi, do you have any idea about this one?


#10

I have completed the assignment my workflow is -

image

Do not worry about that screenshot and get confused our workflow should be proper and run flawlessly


#11

Thank you for your response prankurjoshi.

I think my workflow just like yours, but always failed when system try to invoke “ProcessTransaction workflow”.


#12

Log Message for every workflow, send me the screenshot where it fails


#13

Hey prankurjoshi, thanks for the suggestion, I found it stopped at "Invoke “SHA1Online_GetHashCode workflow”, but I can run “SHA1Online_GetHashCode.xaml” successfully…


#14

So that means you are getting the HashCode from the website SHA1 Online? If not please verify the previous workflow if that is giving you the correct formula for ClientID-Client Name-Client Country


#15

:sweat_smile: it seems like the “select” of New Status is faulted


#16

Try to send some hot keys and set the new status, that will work. in either case you have to play with Tab and Enter


#17

@prankurjoshi
Thanks a lot! I’ve done with it now!:rofl:


#18

Hi @ilemon,

have you managed to complete the assignment? I was having the same Problem as yours. I don’t managed to invoke “extract Client Information”. Can you send me your process file or a screenshot with the invoked Arguments and defined Arguments?

Thanks
Kind regards
Gennaro


#19

Hi @Gennaro_Bozza ,

I actually created a new one then it worked perfectly…
I designed it as what I did in Assignment 1 instead of following the instruction.