Stuck in Assignment 1

Hello Guys im doing Level 3 Assignment 1 I have completed my workflow but got stuck in one place i want to know how can i get WIID in my url file to get the details

after you extract data you have to get one by one datarow in the getTransactionData Workflow and you can get the WIID using assign activity to assign WIID to a string variable.
out_TransactionItem(“WIID”).ToString

ok @Vidwa but what im trying to say is when my project is being executed at the end it just opens SHA1 website but the robot is not getting any data (formula) to type and generate hash code

sha1 is to be opened while it executes. and using type into activity enter

in_ClientID+"-"+in_ClientName+"-"+in_ClientCountry

after click on generatebutton you have to get the hash code using get text activity.

pleae check the image
im unable to get the data which i have filtered (with type and status)

I checked all files and settings looks like my workflow is not getting a missing part when i execute my workflow it (In mid section after scraping data) it logins once again & opens SHA1 website and logs out of the Acme Website its missing a part

check you mapping for the invoke of GetTransactionData
check if the arguments for WIList is mapped correctly.

Also once step behind after you have scraped and filtered the data are you mapping it correctly outside in the Mian variable?

Dear @nadim.warsi first of all thank you for helping me.

I am getting the WIID from get transaction data(Used write line activity to check) i think my main problem is its not taking that WIID and using it inside the navigate to widetails and further to do the procedure.
One more think my process workflow doesnt work if i run it individually i get an error " Object Reference Not Set to an Instance of an Object"

1 Like

the issue is before the getTransactionData part. The WIList is not passed correctly hence the issue is there after where you are assigning WIID.

If you want to run the process independently you have to default all the in arguments otherwise you will receive that error as it expects values.

1 Like

@nadim.warsi

thank you for your help brother i deeply appreciate it i am starting this workflow once again
i hope this time ill create an error free workflow :smile:

Thanks once again

1 Like

Hello @nadim.warsi
So i created another workflow but this item everythings going smooth but theres just a minor issue my workflow types the same name in the Sha 1 website and updates that particular name

1 Like

it could be an issue with your variable.
Share your flow lets have a look :slight_smile:

1 Like

@nadim.warsi I solved my problem and i must say it was a very silly mistake
I deleted all the three sequence in the SetTransactionStatus instead of deleting 3 activities inside those sequences.Now my Workflow is running correctly

Thank You for helping me :slight_smile:

1 Like