Error when using 'Sent Outlook Mail Message': A program is trying to send an e-mail message

email
activities

#1

Scenario:

When using ‘Send OUtlook Mail Message’ activity I get a pop up window saying: ‘A program is trying to send an e-mail message on your behalf when trying to send a Template via E-mail’

I’m using Windows Server 2008 R2 Standard. This server is setup as a High density server where we will have 3 robots installed.

Steps to reproduce:

‘Send OUtlook Mail Message’ activity in a Windows Server 2008 R2 Standard

Current Behavior: Email message can not be sent in UiPath until you click allow in the pop up window

Expected Behavior:

Studio/Robot/Orchestrator Version: N/A

Last stable behavior: N/A
Last stable version: N/A
OS Version: Windows Server 2008 R2 Standard
Others if Relevant: (workflow, logs, .net version, service pack, etc):
The IT team recommended to verify if UiPath is COM compliant as a trusted add-in for relaying the email. I’m not sure if this is relevant.

Any ideas?


#2

Refer this @selrac



#3

The robot stops on the send email activity and it doesn’t progress further until you manually click on Allow. I tried adding the click button but it doesn’t work as it doesn’t move to the next activity


#4

Disable the popup in settings


#5

Well, yes, this is a similar problem, but the process in UiPath is not moving to the next step and UiPath is not giving an error either. UiPath is just stuck waiting in the pop up window for the user to click ‘Allow’. Even I have it in the UiPath process to click ‘Allow’ it doesn’t move to the click activity. I tried the code posted by @vvaidya but I get the same issue.


#6

@selrac
Use Parallel activity and put the sequence that clicks on allow button as the first parallel activity.

In case if there is possibility that the pop up will be shown only sometimes and not for each emails sent, put the Attach window activity in try-catch and handle the catch.


#7

Use Pick branch Activity, So that you can handle multiple cases. After using “Send outlook mail” Take Pick Activity and add two Pick branches in it

1. To click the allow in outlook popup
2. Give any activity like delay or count anything to just bypass the 1st case

Pick Activity helps you to execute any Single possible activity from pick branches

pick

If still you are not able to do this then configure your outlook with the settings in the following link

https://support.microsoft.com/en-in/help/3189806/a-program-is-trying-to-send-an-e-mail-message-on-your-behalf-warning-i


#8

Thanks, That worked. I didn’t know about the parallel activities. A new area to explore. Great!!


#9

I tried doing the same using parallel activity but it clicked on one Allow and froze it out, did not click on next Allow that comes after 5 secs.

Can anyone help with some sample…

Thanks for the help in advance.


#10

@sapta_619, I have a loop to check if the Allow window exists and then I click allow again. Hope my example helps


#11

Thanks that worked :+1:


#12

@Madhavi, the process is getting stuck some times in the ‘allow’ window and I don’t understand why. I tried adding and changing the delay times but I’m uncertain to know what is the best. It generally works, but as sometimes it doesn’t it causes to stops production.

Any ideas on how to make it 100% reliable?

Note that the ‘allow’ window appears twice

The first time I need to press ‘allow access for…’ and ‘allow’
image

The second time, after a loading bar, you need to press ‘allow’ again. Here is where it seems to get stuck not pressing the ‘allow’ in the second window. I have a loop to check if the ‘allow’ window exist. I’m not sure what to do next.

Find attached Email.zip (66.3 KB)
the process I have


#13

Why just don t disable Programatic acces?


#14

Thanks @Gabriel_Tatu, I tested it and it worked. It will simplify so much the programming. Great!!