Community Edition activation - Same Device ID

studio
license

#1

I cannot activate the Free Community edition. I have a windows 2016 server in Azure and it complains about the DeviceID already being registered. The machine was build today and i have never used UIPath before anywhere.

Activation failed with error: 0
Error description: No Error
License status: Device ID already activated, trial not allowed after code activation

Device ID: M2Z0SchGmJjEQTJJwF+y
Computer: RPARobot
User Name: localadmin


#2

Hi,
You cannot go back to Community Edition after activating a license key on a machine. It contravenes with CE terms and conditions.

please take a look here.


#3

Hi @Toni.Vervloet

How was it build? If you’ve never used UiPath before, this means that it’s a cloned machine and the device ID was previously used to activate UiPath.

Our licensing provider (Nalpeiron) assigns a unique device ID for each client that activates UiPath. This is a unique combination of 20 numbers and letters individual for each machine. Using cloned machines, or machines build from the same template will not help you track usage as the Device ID will be the same for all. Therefore we do not encourage this procedure if you notice the machines will have the same Device ID.

Also, if this machine is a cloned one (having the same Machine ID as other machines) you will not be able to use multiple trial versions on it as our licensing provider doesn’t allow to have a trial installed on machines with same device ID (in order to prevent trial abuse).

As a solution for this is to use the System Preparation (Sysprep). Below link for more details.
https://technet.microsoft.com/en-us/library/cc721940(v=ws.10).aspx


Device ID already activated, trial not allowed after code activation
Unable to update CE edition
Unable to install UIPath Community Edition on AWS EC2 Windows instance
#4

The point is that the machine is build via AZURE, there is not control over
how that happens. The concept of SYSPREP does not apply here. MS Azure
provides VMs with Windows on it.
Is there any way UIPATH can find a solution to that ?

I cannot be the first one who tries to run UIPATH on an Azure VM ?

Thx,
Toni


#5

Ugh, it’s because of Azure because of the Azure virtual machine environment. There might be multiple machines in the datacenter with same device ID.

I know how this may sound, but could you please try to restart the machine and see if the device ID changes?(in some cases this worked). Remove first the License folder from%programdata%\UiPath and then try to activate again.


Unable to install UIPath Community Edition on AWS EC2 Windows instance
Unable to renew the community edition
#6

I am having the same issue with a Server I just built in AWS. Any other things to try?


#7

Hi,
I have the the same error, I’m working with a W7 machine downloaded
from Microsoft and runing in Virtual BOX.
Note that all the TEST machines that you download from MS has the same name (hostname=IE10WIN7) Is this a problem for Uipath?

Thanks!!

My error is:


Activation failed with error: 0
Error description: No Error
License status: Device ID already activated, trial not allowed after code activation
Device ID: xmvVzdz3Uw388yxct0pB
Computer: IE10WIN7
User Name: IEUser

Thanks!


Unable to active Community edition of UI Path on AWS
#8

Here you can dowload VM from MS to testing purpose , you can run machines during 90 days:

https://developer.microsoft.com/en-us/microsoft-edge/tools/vms/

Tahnks and Regards


#9

All,
Any idea about the problem reported still no working :-C… Some one know if is possible
to export my actual flows to other installation With my actual Comunity License

Thanks!!


#10

Hi Luggi,

So you still get that error? The problem with some virtual machine you get is that some of them are cloned. That means that the Device ID is the same.

If you have Studio CE installed and successfully activated on another machine, then yes, you can move your workflows.


#11

Ovi,
Thanks for the response!!
But do you know how the process to generate the Device ID is? The machines that I am using has been downloaded from MS
https://developer.microsoft.com/en-us/microsoft-edge/tools/vms

Sure that more people has downloaded the same machine… may be a procedure could be change the machine name before install the Uipath CE and then install the application.

I will try and let you know if works or not…

Thanks!


#12

Please take a look at my response in this post:


#13

Hi,
Finally reinstaled a new machine and change the HOSTNAME (MS default) before install
de UIpath. Now my Comunity License is working again in the new machine, a good practice
would be make “Snapshots” while you are working with VM, (Virtualbox) and back to fresh
environment in case of faill.

Thanks and regards.


#14

@ovi Hi, is it possible for UIPath to help check why an ID is already activated?
I’m wondering if the machine is a clone account and some other machines are also using CE edition or is it because the company also has bought the enterprise editions for other machines. and they all happen to share a device id?


#15

Hi All, I also faced the same issue. I tried to deallocate the existing azure VM and created a new one from the scratch. This time the device ID came different and the lisence got activated.


#16

Hello,
I tryed to renew the community licence but I could not do it.

I donwloaded the community again and now i don´t even have the option to renew licence.

Does anybody know how to solve it?

Thank you very much!
BR


#17

Even i am facing same problem. I got a new laptop and I am getting the same error while trying to install community edition for first time. My device ID is “1unjhsViizrwprC+9vnN”. Kindly remove this machine ID from UIPATH database.


#18

Thanks Ovi. I tried and got the same error.


#19

Hi @Gaogao

See here:


#20

Thank you Maciej.

My problem is that Azure VM shares device ID across environment thus CEUP thinks my ID is activated. I still don’t understand how it expires - might be someone else activates a version via Azure shortly after I did that.

So the post you shared asked the first step - to install CEUP - is not doable for me as now.

I am stuck in this situation since last Wednesday and I still can’t get out of it.

Gaogao