Community Edition activation - Same Device ID

It should still work, see here:

At the time Studio CE is launched it is already installed and you can also launch the Robot Tray agemnt from the Start menu. After you connect Robot to Orchestrator, you can proceed.

Thank you for the prompt response.

My situation is after using the UECP for few weeks, all of sudden last Wednesday it asked me to activate (as if first time using it).

I just tried the recommendations above but realized that I don’t have a “license” key really as I don’t recall receiving one from UIPath.

Again, the situation is in MS Azure VM environment.

Could you post a screenshot of the UiPath Studio CE after you launch it? I’m a bit confused here :smiley:

It should give you this splash screen:

sorry my mistake. Didn’t go to the right step.

Went into the “Acquire license from Orchestrator”. However, I am starting with a CEUP version, and don’t have a “Machine Key”. I presume the Orchestrate URL is “” but not sure if this step applies to me.

I am thinking to give up running this on Azure and just run on a standalone windows laptop. Quite frustrated as you can tell :slight_smile: but thank you very much for your help and patience.

You don’t have to give up now, you are on the right track.

The Machine key comes from the Orchestrator, see here:

Basically, Orchestrator is a web-service that can manage your active robots. But first, you need to connect those robots to the Orchestrator.
The is a free version of Orchestrator that is hosted by UiPath and can be used for testing and learning.

Orchestrator can also provide a license for the Studio if you connect your Robot to Orchestrator, which is the workaround we are talking about :slight_smile:

Please follow the link above carefully and you will have a working Studio :slight_smile:

Thanks again.

Just created first robot awaiting for “machine key” now.

Will keep tinkering for the rest of today … still a bit scratching of my head :slight_smile:

Should the machine key be sent instantaneously ?

If you created the Robot in the Robots tab, please go to the Machine tab and create a Machine with that Robot :smiley: You will get the Machine key from the Machine tab :slight_smile:

Actually, if you followed these steps, you will already have one created:

You can grab your Machine key on the Machines tab then.

got the machine key (the machine was created when the robot was created by me). But I think my robot is not connected to the machine I created.

I feel this is an area I need to go back and do more research here instead of dragging your feet here. But any way I can get over this quickly today you can help will be helpful!

it sort of goes back to the same issue - the Machine I am running is based on Azure hence the machine name is commont - “virtual windows”. I got the error that this machine is connected to a different key.

Could you post a screenshot of your Robot settings and your Machine settings?

The name in both cases should be the output output of the whoami command in windows command line. See here:

You will use that returned name in these two fields:

  1. In Robot settings, it will be the domain\username field:

If the name returned by the whoami command is indeed returning “virtual windows”, then it is an issue I will have to research a bit more.

Thank you again for your help. I stopped using VM now and after that, I realized what mistakes I made :slight_smile: Just like you pointed out. Nevertheless, I will set up robot on the laptop I am using so the lesson is still valuable.

Thank you.


1 Like

Hi @ovi,
Thanks for trying to help out others. Great work.

I am also facing the same problem with the UiPath community edition.
While trying to run for the first time I got the error code -4006.
Uninstalled and reinstalled the studio (community edition).
Now I am getting the error “Device ID already activated” on my brand new Windows 10 official laptop. Could you please guide us on how to resolve.

Already created a new post with detailed description and screenshots, which is under moderation.


After creating multiple VM on Azure free trial, the community edition license is not active.
Same error “Device Id already activated”.
Please anyone assist us.