W10: Proxy error 407

Hello,

My Desktop is running W10 64bit.
When trying to connect from the Robot settings on my desktop, I get the error: “407 Proxy Authentication Required”.
I can reach from a browser https://platform.uipath.com and the problem is that UiPath must provide the proxy authentication credentials.
I’ve seen here Problems running process from Orchestrator online (ServicePointManager) that it’s not possible. I cannot use a VPN or change my company firewall settings.
Here https://docs.uipath.com/robot/docs/redirecting-robots-through-a-proxy-server I read that it could be done.
However, I don’t have any “%ProgramFiles(x86)%\UiPath\Studio” or “%ProgramFiles%\UiPath\Studio” directory.
UIPath is located in C:\Users\username\AppData\Local\UiPath and I don’ find any UiPath.Executor.exe.config file.

Thanks in advance for your help.

Hello

Redirecting robots through a proxy server seems to be outdated. I’ve got 2019.10.2 version of UiPath and these configuration files are located in
C:\Users\< username >\AppData\Local\UiPath\< uipath’s_version >
or
%localappdata%\Uipath\< uipath’s_version >

Hello

Today happen same issues. I’ve got 2019.12.0 version of UiPath.
but 2019.10 version of UiPath can connect to Orchestrator Server.

I confirm config files.

Maybe UiPath add config file [proxy.config] from 2019.12.

A problem fix when I edited this file.

I updated files in C:\Users\\AppData\Local\UiPath\app-19.10.2
UiPath.Service.Host.exe.config
UiPath.Executor.exe.config
NuGet.config
I also added the proxy key in uipath.config (maybe useless)

Then I run UiPath.Agent.exe from C:\Users\username\AppData\Local\UiPath and enter Orchestrator settings.
After clicking the Connect button, I still have this message:
The remote server returned an error: (407) Proxy Authentication Required.
RemoteException wrapping System.Net.WebException: The remote server returned an error: (407) Proxy Authentication Required.
at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
at System.Net.Http.HttpClientHandler.GetResponseCallback(IAsyncResult ar)

For proxy settings, there should be only one file to configure instead of multiple files.

Hello
I changed proxy.config and “machine.config” from .net Framework settings.
Would you like to change this file ?

・Windows10 32bit
C:\Windows\Microsoft.NET\Framework\v4.0.30319\config\machine.config

・Windows10 64bit
C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Config\machine.config

it add below section.

<system.net>
    <defaultProxy useDefaultCredentials="true" />
</system.net>

Thanks very much itsurou_nagai for the information.

I tried updating C:\Windows[Microsoft.NET](http://Microsoft.NET)\Framework64\v4.0.30319\Config\machine.config without updating UiPath files.
I tried updating C:\Windows[Microsoft.NET](http://Microsoft.NET)\Framework64\v4.0.30319\Config\machine.config and also updating UiPath files (adding proxy details).
Unfortunatly, it didn’t work.

When removing the proxy in the browser and sharing the connection with my phone, I can connect to the orchestrator.
So indeed the problem is only because of the proxy.