407 Proxy Authentication Required

Hi, since the community 2021.4 stable was updated, I faced the ‘407 Proxy Authentication Required’ issue when:

  1. Connecting the UiPath Assistant to Orchestrator;
  2. Managing packages in UiPath Studio.

I followed Redirecting Robots through a Proxy Server but didn’t solve the problem.
In previous version such as 20.10.x, this issue could be fixed by adding defaultProxy useDefaultCredentials=“true” in proxy.config.
Kindly check any other solutions or steps I missed.

Both my Studio and robot are using 21.4.0.
Here is the setting surrounding by webProxySettings in the uipath.config under folder %app-21.4.0 and %app-21.4.0\Rules:
add key=“ScriptAddress” value=“http://apwebsense-web:xxxx/proxy.pac” /

@healsko_ho

Check below for your reference

and here

Hope this may help you

Thanks

@ksrinu070184
As I said above, I could fix the issue by modifying the proxy.config in earlier versions. But in 21.4.0, related setting is changed to uipath.config.
Besides, I think I don’t have the admin right to change the machine.config since I can’t save the changes.