Upgrade Version 2022.4 ERROR- UiPath.IdentityServer.Web.Startup The configured Auth0 authority: (null) is not an valid URL

I upgraded to the new version and I got an error -
“UiPath.IdentityServer.Web.Startup The configured Auth0 authority: (null) is not an valid URL”
Did anyone encounter this error?

Hello @Amit_Bendet!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly

Hey together,

we have the same error in out logs.

Did you find a solution for this? :slight_smile:
My thought was, that it has to do something with Windows Auth?

Many Greets,

I’m also getting this error! Did you find a resolution?

Hey :slight_smile:

When you try to log off from orchestrator, do you get a page displayed that says something like „the page cannot be displayed because an internal server error occurred“ ?

I did not find a solution yet, unfortunately.

Are you also experiencing this with on-prem orchestrator?


Check in the Start → Event Viewer → Windows Logs → Application → error/warning logs/ There you will see more details.

Also, you may revert the upgrade and try the Orchestrator v2022.4.2: 2022.4.2

Meet also these prerequisites:

Our group is having the same error popping up in our logs. It is an on prem installation and started happening after we updated to 2022.4.3. This version is a requirement for us as it has a fix for a different bug that was effecting process functionality.

This error gets logged every time someone logs into Orchestrator. It does not appear to be causing any issues but is clogging up the application logs on the server which is not ideal.

We don’t have ExternalAuth.AccessTokenAuth.Enabled in our UiPath.Orchestrator.dll.config file, but my understanding is that it is not a required parameter.

Any guidance on a solution to stop the error from getting logged would be appreciated.

Can you confirm that this was your Error code - 1431?

If yes, we fixed it in Orchestrator 2022.4.4: 2022.4.4

Thank you for the response. I don’t see an error code related to this.

This is what I see in the event viewer

Log Name:      Application
Source:        IdentityService
Date:          10/5/2022 3:30:05 PM
Event ID:      0
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      REDACTED
2022-10-05 15:30:05.4912 UiPath.IdentityServer.Web.Startup The configured Auth0 authority: (null) is not an valid URL
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <Provider Name="IdentityService" />
    <EventID Qualifiers="0">0</EventID>
    <TimeCreated SystemTime="2022-10-05T19:30:05.488404100Z" />
    <Security />
    <Data>2022-10-05 15:30:05.4912 UiPath.IdentityServer.Web.Startup The configured Auth0 authority: (null) is not an valid URL</Data>