Unattended robot not working properly

Hello community,

I’m having an issue with a robot when I try to deploy it on Orchestrator, when I’m connected on the robot session and execute it in attended mode it runs smoothly and finds all the selector but when I try to run the process from Orchestrator on unattended mode it does not find one of the first selectors.

Uipath Studio Pro 2020.10.2 Entreprise Licence
Orchestrator 2020.10.3

This is the error i’m getting :

And this is what I find when i reconnect to the robot session to find where the robot has stopped :

It is supposed to click on the login button, can anyone help me find a solution for this.

Cheers

The exception seems to be occuring in a bring to foreground action.
Are you using some activity or send shortcut to bring the login modal to the front, or something like that?

2 Likes

Also @Rooty you need to show your code. How are we supposed to know what is broken if you don’t show your code??

2 Likes

Hi @Rooty ,

Could you please check below things first.

  1. We should have any on going connections with the VM(bot machine) like user logins. to avoid this we have to restart the VM to make sure that no user logged into this VM machine.

  2. Have you installed the Bot which you are running as un attended from orchestrator by using MSI installer since we must install the bot with service mode since service mode bot is required for un attended automation.

  3. Make sure that you assigned un attended bot license for the Bot(VM) which you are trying to run your process un attended.

please check above points and let us share your confirmation. thanks.

2 Likes

@Rooty Use Activate activity before login button

1 Like

Hi @Rooty

Have an view on the thread

Hope it will works

Regards
Gokul

1 Like

Hello guys,

@kirankumar.mahanthi1 @Gokul001

I’ve tried to follow your advices and went to check if the robot is installed in Service mode which it wasn’t and I had to re-install it but after that, I couldn’t connect my UiPath Assistant to Orchestrator anymore. I’m getting this error: The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel.

I even tried this solution but it didn’t work out :

UiPath Assistant Robot Error

Hi @Rooty

  • May be your connection has been blocked by a firewall settings or organization group-policy settings, check on that.
  • Try to clear all the temp files and restart the machine. Then reinstall Uipath [studio]

Regards
Gokul

1 Like

Thank you all,

I have managed to install the robot in unattended on the robot machine, by following your steps :

And managed to find a solution for the certificate request by contacting the technical support and they gave me steps to follow, that you can find here :

Thank you again for your support.

2 Likes

your welcome @Rooty

Glad to hear that you are able to resolve the issue. nice connecting with you. thanks

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.