Disconnect between Orchestrator and Unattended Robot


I am unsure what the exact issue is with the unattended Robot, but there seems to be a disconnect between Orchestrator and the Unattended Robot. The Unattended Robot is installed on a Virtual Machine, it has it’s own user login. When trying to run any Jobs using the unattended bot, the job is permanently stuck on Pending.

When looking at the UiPath Assistant on the Unattended Robot VM It shows it is Connected but Unlicensed: image
If I try to login to the assistant with the Robot’s login I get this: image
And these accounts should be licensed:

They also have been assigned:

I tested both the username and the email version and neither have worked.

Here are some other screen snips if this helps:

I’m sure there is either something obvious I am missing or a problem with setting up the unattended Robot.

Thank you for the help!


Validate credentials in orchestrator first. Check the credentials of robot in orchestrator.
Also check Virtual Machine robot is connected with orchestrator?
Also check robot is connected with specified machine?

Once you validate above three checks it will start working.


Pls disconnect the robot from UiPath assistant and ensure that these steps are followed while connecting unattended robots

And I could see all the details are looking fine as per the screenshots provided

So pls check the below conditions if it doesn’t work even after reconnecting
—make sure your process is tagged to the right environment with the robot and your machine is connected with
—and check the username, domain, password provided along with robot settings
—in your server where robot is hosted, try once running from UiPath agent
If it’s not running then open Start → Services → search for UiPath Robot and start or restart the service

Once after restarting try running the bot either from agent or from orchestrator

Try these and pls let k ow for any further queries

Cheers @deguy42

Thank you for the help, will try both of your suggestions and come back to you!