Trouble connecting unattended robot to orchestrator

Hi all,

I have a problem with connecting my unattended robot to the orchestrator. When I log on to the machine of the robot and i Manualy connect the robot to de orchestrator.

But when I log on to the machine the robot doesn’t connect automatically to the orchestrator. I always need to select the orchestrator URL en hit the connect button. After I have done this running a proces is no problem.

orchestrator1

Is it possible the robot agent connects automatically? So I don’t have to log on the machine first. I have a onpremise installation of Uipath.

Greetings,
Martin

Hi @martijn.vanson
I’m not 100% sure of the reason why you always need to redefine the Orchestrator settings but I could suggest a few things to check.

For unattended robot, the best practice is to install the robot in service mode. This means selecting “Register as Windows Service” during installation. You can actually check if robot is running in service mode by checking if you have “UiPath Robot Service” listed in Windows Services and it is in “Running” state.

Hi Matthew,

Thank you for your answer. But this service is running on the machine.
And we still have the problem. For now we use de command line to connect the machine to the orchestrator after the reboor of the machine.

But this is nog a solutions we would like to keep. There must be another solutions?

Greetings,
Martijn