Unable to run automations after rdp disconnects


previously i have created some post regarding same topic and tried most of the soilutions availble on net.
i have explained here how we are connecting to remote.please check below link.

initially i thought issue is due to new version of mremoteng but toiday i insatalled same old mremoteng and tested on vm but still not work.
So i guess conclusion is change of new bounce server is the only issue becasue now rest all is same.
new bounce server have more secuiry as well as it is showing at the to “identity of the remote computer varified by server ceryificate”
when i click to vew ceryificate it shows below.please cehck both ss.

normal clicks working fine but image automation not working after rdp disconnects.
please if you have any idea how security is affecting to image automation please update us.
@sandipauti @mayank.te @srinucslt @SUJIVENKAT @adrian @badita @rupeshkumar.shah @niteesh2004 @xzci @pavan07 @cclements @Tiberiu_Niculescu @BarbaraSajo @gregory.lavranos @AndyMenon @Ravi_Chotaliya @Mr_Meeseeks @Pablito @lakshman @J0ska @Gokul001 @NotFranmax@Trracer @Palaniyappan @Lidia @ddpadil @palindrome @hacky @Florent_Salendres @Pablo_Sanchez @PD2 @Sudarshan_Kale @postwick @rahulsharma @Romano @Guilherme_Silva @vmariejeanne @Pontus_Varghav @theerthaks @badita @loginerror @jibanjyoti @gregory.lavranos @ahmedzaidi @Vrushali_Gave @cschevuri @rahulsharma @postwick @opggho @theerthaks

I suppose you are constantly searching in wrong direction :frowning: - as per our previous conversation.
You have your robot set-up as ATTENDED and in such case (according my experience) it will NOT work when you disconnect from the RDP session.

There are several forum posts about unattended robot set-up scheduled via windows scheduler. I already pointed you to some of them.


yes , i checked all i agree to your point.
but we have similar setup previously also and still we have that and on that it is working correctly with no error.here only differece is new bounce with added security.
so i think i am missing some point to check with this new boucne server.
old setup is not yet dicomissioned beause we have some automation which need to run at night time but people from ITteam will dicomisoned that in few days.so we are finding solution for new bounce , we are still using old setup as with new automations not work after rdp disconnects.

I really do not know how you made it working in the old setup. Somehow the RDP session stays openned even after disconnecting from it. I never seen this.

In your case I would concentrate to set-up true unattended robot e.g. based on this post - old but still valid until version 2021.4

Key points are:

  • make entry in Credential Manager “UiPath:user=<domain\username>”
  • scheduled task is running under <domain\username> with settgin “Run whether user is logged on or not”
  • UiPath.Service.Host.exe installed and running
  • UiPath.Service.UserHost.exe NOT running under <domain\username> account


1 Like


finally issue got solved.
need to run bat file on dev/prod directly to disconenct.
we are initially tried on bounce server.bat file mentioned in below document.
thanks for constatly updating us with comments and solutions.

1 Like

Interesting. So this workaround allows running attended robot in background :+1:

Yes , u can also try and let me know .

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.