Run UiRobot process from Windows 10 Task Scheduler

HI,
I want to have UiRobot loaded and running process if restart of computer because of update happens. I have community edition of Ui Path studio and I’m running Windows 10 (english version) 64x. This is what I have
Location of UiRobot.exe
C:\Users\TOM\AppData\Local\UiPath\app-2016.2.6162.37289\UiRobot.exe
Location of process I want to run
C:\Users\TOM\Documents\UiPath\TEST 1\Main.xaml
Location of package
C:\ProgramData\UiPath\Packages\TEST_1.1.0.6188.20716.nupkg

I tried to make something out of


and

but no win there.
Please advice how to solve this

5 Likes

The only drawback is that CE autoupdates. Next time UiRobot might be located in another app-xxx folder. I guess that can be automated too with a script, not with UiPath.

1 Like

Thanks for that warning. As I’m targeting just start up, I added shortcut to startup in windows, but now, with UiRobot changing folder location, that doesn’t work in the long run. Thanks

This only works if you run it in an active session. I have tried a number of options to run it session 0. Including:

  • Having sequence that launches the Workflow Interactive
  • adding /process or /invoker.
    Can uipath please provide clear documentation on how to best schedule a task to run irrespective if the user is logged on or not? There are a number of articles, but none seem to be conclusive.
3 Likes

Hi @thuylam,
DId you get any solutions for the same problem? I am also facing the same problem.
@badita can you please help us on the same?

Thanks,
Jiban

+1. I’m looking towards a resolution to this, as well.

Even though the documents say this is unsupported this works for me. Note that if you are logged into the virtual server and run the schedule to test you will be immediately logged out.

  • Open Credential Manager->Choose Windows Credentials and add a** new Generic Credentials** with the following format
    • Internet or network address: UiPath:user=<domain\username>*
    • User name: domain\username
    • Password: Your user’s password

Docs are here: https://www.uipath.com/kb-articles/how-to-schedule-a-process-manually

2 Likes

Hi, @bobpeers.
I have done same as mentioned but no success for both logged in & logged out session
Do we have to mention a version of UiPath in Windows generic credential? as shown in document

UiPath=user:<domain\username> v8.1.5855.24349 - v2016.1.5942.30558

Hi @Neeraj83,

actually if the user is always logged in then you don’t need the UiPath=user part I just have the robot to run only when the user is logged in and in the actions you need:

“C:\Program Files (x86)\UiPath Platform\UiRobot.exe”

Plus the arguments look like:

-file “path to file.xaml” --monitor

If I manually start the script I am then logged off the server and the robot runs. This robot runs every night at 1am without issues.

Hi @bobpeers
Thanks for reply!!
I have achieved the scenario if the user is logged in now I want to try for non logged in user.
as per given steps below configuration is done.
a) Task schedule through Windows Task Scheduler with all above steps
b) Set Windows Generic Credential
c) Set Run whether user is logged on or not in Windows Task Scheduler.

All above points are configured still the process is not getting executed.

Any updates on this? I am also having the same problem. Thanks

Hi @ahiller,

This feature is no longer supported. We recommend using UiPath Orchestrator to schedule all your automation projects.

Regards,
Arivu

In case of using domain account as service account for robot it is essential to use this format including domain otherwise robot will fail with error “Executor start process failed”

Hello @Neeraj83,

After you have done a) & b). Just change from “Run whether user is logged on or not” to “Run only when user is logged on

Prerequisites for this to work are:

  1. Robot version 2018.3 is the last to support --monitor. Hence you must be on Robot version 2018.3 (Including all minor versions) or lower. Details here.
  2. The system account used to create the task must have logged in to the system once and its okay if it’s in locked state.If the user is Signed out it does not work.

Kudos :slight_smile: Hope this helps !

Regards,
Nithin Prabhu

Hi,
Tested with 2018.4.1 and it still works like before.
Cheers,
Josef

Hello bobpeers

Can you please eloberate it. I am trying to schedule my task using user logged in or not option. Is it possible. If not can you explain me what the other option is. I have seen your posts but I am in bit confused

Not sure if things have changed but I can only run schedules if the robot user is logged into the server. We leave them logged in all the time and just disconnect the RDP session when done.

Thanks for your prompt response. I am scheduling it in VM from my desktop. So, when I use “Run only when user is logged on” I tried to come out of VM to desktop by keeping the login session without disconnecting. But, when I came out of it, it stops executing SAP and remains at the same please. Could you suggest me on the same

It’s Clear It’s no possible with Latest Versions of UiPath. Consider close this topic and make a special note in Documentation so People can be aware of this limitations.
Thanks