Unable to run script after disconnecting VM / after doing system shutdown


We are connecting VM using Remote desktop connection and the using MremoteNG we are connecting to production server.
Once shutdown my laptop , automations which are running on vm stops working.
We are not using orchestrator , we are running automations by using batch files and thiose bath files we sheduled on task scheduler.
OS : windows server 2012 r2
Uipath version : 2021.4.4
Please check below ss.

Please help me on same.
@Trracer @Palaniyappan @Lidia @ddpadil @palindrome @hacky @Florent_Salendres @Pablo_Sanchez @PD2 @Sudarshan_Kale @postwick @rahulsharma @Romano @Guilherme_Silva @J0ska @vmariejeanne


I hope you are using Attended Bot licence here. If so then you can’t disconnect from VM while Bot is running as it won’t run in the background.

we are using unattended bots

HI @Mathkar_kunal

Then can you check the settings with the following settings in the threads and change the settings accordingly


As we are not using orchestrator how to check or where to check service host is running or not?

@Mathkar_kunal ,

From my working knowledge, the bot can not perform action or work under a system shutdown. in this sense, the unattended bot can work under the screen lock of the system. the bot can perform a background process while its simulation click activity is active.

If you have Unattended robot. I’m damn sure you are have an Orchestrator.

Task Manager → Details

Refer the above thread, It has all the step



we are scheduling via task scheduler using batch files
check beow ss

It was working perfectly initially .recently we chnaged just version of mremoteNg nothing else.resolution and all is all same.even we are login it is running fine but once we logout our system/laptop then it wont work

@Mathkar_kunal , then it’s better you let VM on. and run the bot from the laptop and try shutdown or lock it out. I tried this long back and it worked fine. while the main system(VM) is on.

@Mathkar_kunal Go to the unattended licensed VM and check the Task Manage that i mention in the above post


yes i already sent ss.
check below it is from unattented licnese vm only.

tried same , bot not woking . i have not disconnected vm just shut down my laptop and then when i connect again after some time , browsers are just open with specified link but no action is performed like click .

Uipath.service.Host.exe is not running in your VM


ok then how to unable it? i need to reinstall uipath?
please sugest me for same

Yes @Mathkar_kunal you need to reinstall the Uipath studio. Set Robot type as Service Mode and it will work


while installing uipath and robot it gives option for this selection?for robot type
? if yes u have any ss of that

Can you share the screenshot, I am not able to get you @Mathkar_kunal

In UiPath root folder start command
UiPath.Service.Host.exe install


Robot Type select the Service Host