Automation is not working in Remote Desktop

Team, I have a web application in a remote machine where actually uipath robot is installed. The issue is when the RDP session is opened, the bot is working very well. but when disconnected and triggerred from orchestrator, it is unable to click and type. Kindly suggest.

Note RDP machine has Windows 10 OS

No worries
make sure that the properties in click actiivty like simulate click is enable
and in type into activity properties like clickbeforetyping, emptyfield, simulateclick are enabled
–make sure that these click and type into activity are used within appropriate attach window or attach browser activity (if browser is used)
–and also use a MAXIMIZE window activity as the first activity in the sequence once after opening any application with open application or start process activity so the screen gets to full window and bot will be able to access the elements

Hope this would help you
Kindly try this and let know for any queries or clarification
Cheers @theerthaks

Try using Computer Vision… Works like wonder a lot of time!!!


I am not sure if this will help , but can try once to set the resolution in orchestrator same as that of your VM.

FYI - in orchestrator you will find option to set resolution.


@theerthaks Make sure you are using the “Windows Remote Desktop Extension” configured in the environments the bot will run.

Thanks all for your help. I just want to highlight my issue. The problem is occuring because the image automation does work on minimized window. So when the remote desktop is open on my machine the automation works but as soon as I minimize the window or close the session, the automation stops working. Is there any fix for this issue ?

1 Like


I am having the same issue. Did you find a solution?

I have tried everything mentioned here, but does not work. Even the CV option does not work when the connection is closed.


@mano1982 Not till now. Still facing difficulty with the same issue.

@mayank.te @mano1982

Are you running the bot on your desktop and having it interact with a remote desktop, or are you connecting to a remote desktop and then starting the bot on that machine?

Bot is running on the machine not on my desktop

So, you open the remote desktop, and then start the bot, and after it starts, if you minimize, the bot stops working?

Yes. it happens like that. Also, If i keep the session open the bot works perfectly.

You cannot run the bot in this manner. If you open the remote desktop and start the bot, effectively it is under the control of your desktop - so when you minimize the remote desktop, the controls to the bot are lost and it will hang. The only way to run the bot on a remote desktop is to trigger it unattended.

Basically, if you start the bot and can watch what is occurring, then you must leave the window open, and cannot use your keyboard/mouse. I think this is a windows thing, not UIPath, as AutoIT does the same thing when used on a Remote Desktop. UIPath has the Unattended bot featured (triggered from Orchestrator or API) so that you can run the bot on a remote desktop - but you can’t be logged into that session and watching.

1 Like

Try the following:

Run the robot while rdp is minimized:

This solution has to be applied to any machine that wants to use it.

And to run while rdp is closed:

This solution is applied to the virtual machine. Any user that wants to use it, can click on the .bat file on the VM desktop, once the robot is running.

We had same problem. Solution: Log Out from the sesion where the robot is executing by clicking logout button every time you do not use it. If not, the resolution of the RDP remains as it was and the robot does not work properly using the one on de Orchestrator.
Check the “Log to console” is set to False in Studio config file in the installation folder.
Sorry for my bad English.

1 Like

Did all mentioned options still not working.

Also faced the same issue.
Why don’t you try run automation in PIP mode.
It’s work for me.You can run UI automation either closing RDP session or minimising the session.



this happened to me once on a project for a client, the way i fixed it is by enabling “simulate click” or “send window message” properties for the UI interaction activities(i.e. click and type activities)

I had the same problem.

I solved it by enabling picture in picture for the given process. You can do this in the project settings in UIPath studio. However, such processes cannot be started from Orchestrator, but a somewhat ugly workaround to this is to create a process that starts the PIP process from UIPath assistant. You then trigger the starting process from orchestrator, which in turn, triggers the actual PIP process.


we are also same issue.we are triggering from tsak scheduler.
with simulate click our issue also solved but for clicks only.
for image automation like click image or hotkeys it is not working.
any idea how can we run image automation whenrdp disconnects