Automation is not working in Remote Desktop

Team, I have a web application in a remote machine where actually uipath robot is installed. The issue is when the RDP session is opened, the bot is working very well. but when disconnected and triggerred from orchestrator, it is unable to click and type. Kindly suggest.

Note RDP machine has Windows 10 OS

No worries
make sure that the properties in click actiivty like simulate click is enable
and in type into activity properties like clickbeforetyping, emptyfield, simulateclick are enabled
–make sure that these click and type into activity are used within appropriate attach window or attach browser activity (if browser is used)
–and also use a MAXIMIZE window activity as the first activity in the sequence once after opening any application with open application or start process activity so the screen gets to full window and bot will be able to access the elements

Hope this would help you
Kindly try this and let know for any queries or clarification
Cheers @theerthaks

Try using Computer Vision… Works like wonder a lot of time!!!

@theerthaks,

I am not sure if this will help , but can try once to set the resolution in orchestrator same as that of your VM.

FYI - in orchestrator you will find option to set resolution.

Regards
Ahtesham

@theerthaks Make sure you are using the “Windows Remote Desktop Extension” configured in the environments the bot will run.

Thanks all for your help. I just want to highlight my issue. The problem is occuring because the image automation does work on minimized window. So when the remote desktop is open on my machine the automation works but as soon as I minimize the window or close the session, the automation stops working. Is there any fix for this issue ?

1 Like

Hi,

I am having the same issue. Did you find a solution?

I have tried everything mentioned here, but does not work. Even the CV option does not work when the connection is closed.

Thanks.

@mano1982 Not till now. Still facing difficulty with the same issue.

@mayank.te @mano1982

Are you running the bot on your desktop and having it interact with a remote desktop, or are you connecting to a remote desktop and then starting the bot on that machine?

Bot is running on the machine not on my desktop

@mayank.te
So, you open the remote desktop, and then start the bot, and after it starts, if you minimize, the bot stops working?

Yes. it happens like that. Also, If i keep the session open the bot works perfectly.

@mayank.te
You cannot run the bot in this manner. If you open the remote desktop and start the bot, effectively it is under the control of your desktop - so when you minimize the remote desktop, the controls to the bot are lost and it will hang. The only way to run the bot on a remote desktop is to trigger it unattended.

Basically, if you start the bot and can watch what is occurring, then you must leave the window open, and cannot use your keyboard/mouse. I think this is a windows thing, not UIPath, as AutoIT does the same thing when used on a Remote Desktop. UIPath has the Unattended bot featured (triggered from Orchestrator or API) so that you can run the bot on a remote desktop - but you can’t be logged into that session and watching.

Try the following:

Run the robot while rdp is minimized:


This solution has to be applied to any machine that wants to use it.

And to run while rdp is closed:
https://support.smartbear.com/testcomplete/docs/testing-with/running/via-rdp/keeping-computer-unlocked.html
This solution is applied to the virtual machine. Any user that wants to use it, can click on the .bat file on the VM desktop, once the robot is running.