Unable to instal System.Diagnostics.Debug

Hello :slight_smile:
I’m starting with UI Path, using the RPA Developer Foundation course.
And, following the different steps, i’m meeting a problem : when i want to display a Write Line (as indicated in a tutorial) i dont have “Programming>>Debug” in the Activities panel…So I tried to instal the “System.diagnostics.debug” activity but each time, it ends on “Installation failed”
Any idea please ?
(For information, here is my UI Path version :slight_smile:Studio Pro 2020.10.2-beta.4 - 22/10/2020
Community License
Programme d’installation EXE
Fournisseur de licence : Orchestrator
Mettre à jour le canal: Aperçu
Microsoft Windows 10 Enterprise 64 bits
Version 4.8 de .NET Framework )


Hello! Do you have the UiPath.System.Activities added as a dependency to your project?

Hello Tudor Sandu,
Thanks for your answer.
For the UIPath.System.Activities dependency, i’ve checked and i have this dependency in my project (the same version as well)
I’m wondering if maybe it’s because i’m using a Community Edition of UIPath Studio ?

No, that has nothing to do with it. Can you search for “Write Line” in the Activities panel search box and post a screenshot please?

Well, i have to say that i dont understand what happened…but i have been looking for the screenshot you asked…and there, i can get the Writeline activities, and the Log message as well ?!! :thinking:
Conclusion : the bug was me, not UIPath Studio :wink:
Thanks again Tudor Sandu :ok_hand:

1 Like

The categories are localized, so there would be no “Programming > Debug” in French, but “Programmation > Debogage” instead. Glad it all worked out.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.