UIPath.System.Activities V 22.4.1 missing activities

It appears this latest version of the package is missing a number of activities. I noticed after I started updating dependencies when all of a sudden my processes wouldn’t validate. Specifically due to the System>File>Delete no longer existing.

Here’s the screenshot from V 21.10.4

And this is the screenshot from V 22.4.1

It looks like I now have to go back and downgrade that dependency in my processes and libraries. AAARGH!


Hi @carlor

check the below post it might help

Hi @carlor

Could you confirm the type of the projecr that you are using on the above screenshots?

Is it Windows - legacy, Windows or Cross-Platform? The latter two might still not have all the packages available.

However, I’m not sure this is the issue as your current projects shouldn’t have been affected.

1 Like

All my projects are Windows-legacy.



Can you aslo share a screenshot of the Project Panel? Where dependencies are listed. I want to check if System activities are installed properly. Also, have you tried using search in the Activities Panel?

Below is a screen shot of the project panel including the XAML code that is complaining about the Delete activitiy. Note that search does not show the Delete and my initial post shows what is unde the System activities.

Also, I just noticed in the output window I’m getting the following:

I just tried creating a simple project from scratch with V 22.4.1 and adding a Delete activity and it works, so I’m not sure why this is failing.



Any chance you could share the faulty workflow file, maybe via a private message to me or @alexandru?

Alternatively, share just the code snippet from the XAML file of a working Delete activity and the “broken” one from the screenshot above?