UiPath With ftp session

Hi All,
I Opened FTP connection and trying to uplaod files using “With ftp session”.
It is connecting to FTP server but not uploading files . I have seen many posts regarding the same issue but i don’t see any clean resolution till now. Anybody has any luck with “With ftp session” uploading files?

thx
ramesh

Which FTP activity are you using? UiPath.FTP.Activities?.
And are you using (unsafe) FTP or sFTP.

edit: what do the logs say?

@rameshpola
i gave it a quick try. The official package still doesn’t work indeed with FTP or sFTP. But when you get the package from Go! it will work. Check this link: SFTP and FTP Activity Working
Give it a try for an FTP connection. I only have sFTP connections available

Yes I am using UiPath.FTP.Activities and trying connect through sFTP. It doe snot show any error .
It says all is successful and does not upload files to sFTP location.
As you suggested I Tried downloading from Go! and I see it is the same version of UiPath.FTP.Activities.
Did the SFTP work for you after downloading UiPath.FTP.Activities using Go! ?

it did for me. The Go! package looks the same but isn’t
The official package is version: 1.0.6479.13206
The Go! package is version: 1.0.7053.27728 and has releasedate: 2019/04/24
So make sure you have the correct one installed.

can you share some screenshots on what you have?.
I added an example. If you get prompted about the ftp package missing, install the one from Go!.

Change the settings in the xaml
Object: With FTP session
Credentials:

  • Password: “your-password”
  • Username: “Your-ssh-username”

Security:

  • Accept all certificates [v] (if needed)
  • Select Use SFTP [v]

Server:

  • Host: “your-domain-name”
  • Port: your-ssh-port (without quotes)

Object: Upload Files:
Input:

  • Local Path: “D:\HomeLab\bla.jpg” >> change this with your file to upload

Options:

  • overwrite [v]

output:

  • remote path: “/var/www/html/public_html” >> change this with your remote folder

Example:
Main.xaml (5.3 KB)

3 Likes

Its not working for me . I have same version as yours downloaded from Go!
I downloaded you Main.xml and made changes as per server configuration and still does not work. No errors showed it says process is successful but no files copied to FTP server side.

FTPVersion|690x411

Can you see anything in your server logs?.
If you try with Filezilla or other sFTP client, does that work?
The connection could be refused. Is downloading a file working? You have might have to try the other options.

Yep its working now . We have some issues on our FTP server which we fixed. But its combination of issues , first one need to get the right version package from Go! and then make sure FTP sevre configuration is fine too. Thanks for your help.

Thx
ramesh

Glad you got it sorted out. Debugging can be a tough thing to do, especially to pinpoint what the problem could be. Please link this topic as solved, it might be usefull for others

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.