UiPath Apps Widgets is not added to UiPath Assistant, after creating Automation Ops policies

I have created a Governance policy for UiPath Assistant in Automation Ops as shown below.

But after deployment of Widget policy, UiPath Apps widget is not appearing in UiPath Assistant. In this uipath docs, they have mentioned apps widget is automatically enabled via Automation Ops policies. But its not working.

Anything needed to be configured?

Hello @dhanushrig!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly

Hi @dhanushrig,

Have you tried signing out and signing back in post enablement?

Also is there any app that you have published?


Hi @sonaliaggarwal47 ,

Yes I have tried sign out and sign in again method, and also I have 3 apps published.

When I changed the licensing type to Attended User, Apps widget appeared in the UiPath assistant. But there is some error being logged everytime when I try to open UiPath assistant.

The error is given below,
{“message”:{“identifier”:“WidgetController:_tryInstallNugetWidgetFromFeed”,“msg”:“Error while installing nuget widget”,“err”:{“name”:“SyntaxError”,“message”:“Unexpected token < in JSON at position 0”,“stack”:“SyntaxError: Unexpected token < in JSON at position 0\n at JSON.parse ()\n at C:\Users\username\AppData\Local\UiPath\app-21.4.4\UiPathAssistant\resources\app.asar\main.js:103:694801\n at processTicksAndRejections (internal/process/task_queues.js:97:5)”},“type”:0},“level”:“error”,“timestamp”:“2021-08-30T06:53:12.585Z”}

Hi @dhanushrig,

What license type were you using before changing it to Attended?

Also, this error looks somewhat similar to what we face sometime when bot tries to install packages during process execution.

Have you tried to manually copy nuget package for your apps in location mentioned and then see if it works?

Also might be worthwhile to check the username you are trying to do this has permissions to install packages on your local.

Additionally, I would also suggest to do a quick check on below:

Go to your command prompt on the machine you are trying to run the attended process on, type “whoami”, and cross verify that domain\username for the attended bot in the user settings as seen below:


Hi @sonaliaggarwal47 ,

Earlier, the inherit license from user’s group was selected as my license type, and I guess it was for unattended mode.
And moreover UiPath apps widget will only get reflected in interactive signin mode right? I understood that interactive signin is same as user mode. But I don’t know the reason why UiPath assistant is displaying the apps widget on changing the robot license type from unattended to attended user?

Also, I am not sure about the location where the nuget package of the apps will be. Any idea where it will get stored once the app is published in Automation cloud?

And how to check whether the user has permissions to install packages in local? Do the user needs any admin rights to install?

Dhanushri G