UiPath Advanced Assignment - 1. Having some trouble!

studio

#1

I just tried the UiPath Advanced Assignment - 1. While running it, i am getting this error. I have no idea what to do. Please someone shed some light on it.

“System error at initialization: The given key was not present in the dictionary. at Source: mscorlib”


#2

Hey @vmaneesh94,

Make sure that you have saved the correct data in the config file and given the exact key value while invoking in the workflow!


#3

This is what i gave as credentials


#4

Hi Maneesh,

We are also trying to complete assignment 1 but unable to complete whole process based on (Calculate Client Security Hash) document. Help me .

Priya :slight_smile:


#5

Hey @vmaneesh94,
can you also show me what values you’re giving to the in_Credential argument while invoking the login workflow please?
Seems like your values in the config, orchestrator,and arguments do not match.

I’m assuming you have already created an asset in the orchestrator with the name UiDemoCredential_REFramework?


#6

Hi @Priyahk,

What problem are you exactly facing? please give a brief description.
If there is an error message, please attach a screenshot as well. :slight_smile:


#7

Yes I have. I have the same asset name in orchestrator as well as the Config file and im also giving the same value for in_Credential. I tinkered around a bit but im getting the same error. its hard to explain what is actually wrong since this is my first time working on it.! is there anyway to tell you the exact error?


#8

can you show me all the values you are setting for the imported arguements while invoking the login workflow please?


#9


#10

I’m sorry i may not have been clear.
I meant the invoke workflow arguements for the UiDemo_Login file.
Must have invoked it in the main workflow!


#11

i have not given any arguments for the invoke workflow for Uidemo_login file. Should i give the same arguments that are in the UiDemo_Login file?


#12

@vmaneesh94 Yes buddy,that is where the problems is then! you have to supply some arguements to the In arguements!

Not the same arguements!
If i’m not wrong you must be seeing 2 arguements there? one for the url, the other for the credential?
Plus the config file you posted a while ago had no url setting there! there must be one!
please go through the walkthrough one more time!


#13

hi Rishabh,
Will you tell the step wise … flow to continue… now i’m starting again…


#14

Hello @Priyahk,
The flow is very well in defined in the walkthrough!
Begin with individually creating and testing the workflows as defined in the walkthrough!
Once done let me know i’ll help you in how and where to invoke them :slight_smile:


#15

hi rishabh,

While creating individually only i’m struck… the follow. :frowning:


#16

Where exactly?
I’m sorry but it’ll be extremely difficult to explain each and everything!


#17

Yes, I’m learning but not clearly know about all activities… but I should complete my assignments… it’s requirement


#18

Hey @indra,

Could you please help?


#19

@Rishabh_Lakhera My level 3 course is in process after completing I can help


#20

Alright thanks :slight_smile: