Doesn't run the workflow inside InitApplication workflow

Hi,

Someone please tell me what’s wrong with my below code. I am new to this Uipath.
Now I am trying Assignment 1 from Level 3.
While trying out the assignment, first I encountered with the following error:
“System error at initialization: The given key was not present in the dictionary. at Source: mscorlib”,

But later it is resolved. Now I can see that my login workflow inside InitAllApplication, doesn’t run at all.
and it directly moves to Get Transaction state. Since I am yet to work on Get Transaction, it is giving error.
But why login is not working? If I run login workflow separately, by harcoding the URL, it works properly.

I am stuck in this since 2 days, not getting any solution. And please let me know, the way I have passed in_Config argument from init state to initAllApplication to Login to System1 is proper or not?

Thansk in Advance.
CalculateClientSecurityHash.zip (503.0 KB)

1 Like

So i went through your code and it seems you have no assigned the arguments.

Suggestion:

  1. You dont need to use the password and email arguments for this as its not required. Also you have created them as ‘In’ type which means you have to assign them values during invoke which you wont have at that time as you are using GetAppCredential inside.
  2. In the getAppCredential you have not mapped the in argument for Credentail argument
  3. You have created same names for your ‘email’ and ‘password’ arguments as well as variables. This is incorrect.
    As a standard use in_ or out_ for arguments to better readability.

Please let me know if it works for you :slight_smile:

1 Like

@nadim.warsi, thanks for your suggestion.

I have made changes as per your suggestion. But I am getting error for invoke GetAppCredential.
Please refer the attached screenshot.
Is something wrong here?

Hi Nadim ,
level3.zip (1.8 MB)
Capture
can you help me with workflow. it’s been more than a week I am struck this problem, i have followed all steps mentioned in walkthrough but still it is giving me an error saying - system error at initialization. I have attached the error screen shot and my workflow. please help me with my error . Thanks in advance

regards,
Anil.M

2 Likes

The Value for your Argument on the Invoke Workflow File of Uidemo_Login.xaml that is inside of the InitAllApplications.xaml needs to change as follows:

Current Value: “UiDemoCredential”
New Value: in_Config(“UiDemo_credential”).ToString

Also, the value in your Config.xlsx file (Uidemo_credential) needs to match the name of your credential asset in Orchestrator.

HI Tjust,

Thanks for Replying.
I have changed the values in Uidemo_login.xaml as you said it is now opening uidemo application and entering the credentials in application . it seems INIT is working fine . But now it has thrown an another error please have a look at attachment.

Regards,
Anil.M

what are your passing in the queuename ? can you please share a screenshot of gettransactionitem?

Hey Nadim thanks for replying , it worked later on

1 Like

L3A2-lastes- to send.zip (2.2 MB)
Hi Nadim, I had invested more than 1 month on this assignment still not able to resolve this issue. donno why but every time it is processing only one transaction(WIID) in a loop.i have attached my entire code , if you run you will find only one WIID client details are getting pasted in SHA1 website every time.

Help me with this please .

thanks in Advance

@armamidwar Probably you missed incrementing transactionNumber. Check this once.

where to increment transaction number because the default value for transactionnumber Is 1

@armamidwar Please check when Invoking SetTransactionStatus workflow under finally section of Process Transaction State you are passing correct arguments.

In that Workflow only TransactionNumber will be increased by one as I/O Parameter.

1 Like