To Execute Processes, please activate a license.-Community Edition

@sandeep13 I just restarted my machine and it works fine now. But one thing I am not sure is, everytime this happens either should I uninstall studio and reinstall it or restart the machine every single time.
Could you please let me know a fix for this problem if you are aware of any…
Thanks

1 Like

It will automatically fix by uipath shortly I think

1 Like

I faced the issue again. I restarted the machine and it worked fine. But could you please guess whats the cause for this issue with the studio.

I have no idea about that.
@loginerror @Pablito guys please help on this

Thanks

1 Like

It might be related to Studio auto-updating but the processes for the Robot not re-launching properly. This would explain why a simple computer restart helped here -> it restarted the new process for the robot.

I would certainly first try the restart if the issue occurs again. Only then reinstall from the latest installer.

1 Like

Still facing same issue. Has anyone found a solution besides machine restart? Please help!

Hi @SRay

Normally the solution to restart the machine needs to be applied only once, assuming the error comes from the wrong version of service running in the background (the restart would let it launch the latest version and that’s it, should work from there).

Another solution, which assumes the service is not the core issue here, is to connect your Robot (search Start menu for it) to Community Orchestrator and license your Studio this way.
See here for the way:

1 Like

Ok… this is crazy… but this is what i have tried & seems to be working. There is a file UiStudio.v2.settings in the UiPath folder. Whenever it gives an error, go & delete the file. DOES NOT require to restart Studio!!

Hi @loginerror,
I reuse this post.

I face the same issue in 2019.7 Community when the robot service UiPath.Service.Host is installed and disconnected from Orchestrator.

Studio starts just fine using the “Internal” license provider but any attempt to run a process I receive the error message like in subject.

Regutil returns the following license info:
License code: NALPNA
License status: 2
Device id: eue4pAk5+AAT14xN3IBS
License expire date: 12/6/2019 6:04:08 PM
Maintenance expire date: not set
Subscription expire date: not set
Attended: 0
Unattended: 30
Free: 0
Dev: 0
AttendedConcurrent: 0
DevConcurrent: 0

Any idea?

Hi @J0ska

Is it possible that you had the Enterprise version installed as well on the same machine?

Normally all licencing issues with the Community Edition are easily fixed with a fresh installation of Studio:

Hi,
Yes, I did and uninstall it. I will read through the post you linked.
Thx!

Hi @loginerror,
So I did all steps like described in the post and still have the same issue :frowning:

Pls note this is only problem when robot service UiPath.Service.Host is installed and robot disconnected from Orchestrator.

:frowning: :frowning: :frowning:

Normally the issue is fixed by clearing the licensing folders here and here:

%userprofile%\AppData\Local\UiPath\License
%userprofile%\AppData\Local\UiPath\LicenseInternal

And then re-activating your Studio. It is strange that it would persist after full fresh installation though.
Did you have to re-register your Studio upon reinstallation?

Yes, I did re-register. It seems the UiPath.Service.Host service is not taking the same license…

Could you try clearing this folder here:
C:\ProgramData\UiPath\License

Hi,
I did but it did not help neither :frowning:

But maybe I found the root case (but not yet workarround)

When the UiPath.Service.Host service is installed it is running under LocalSystem account.
The path to folders with license files is %userprofile%\AppData\Local\UiPath
Given that LocalSystem and actual user (e.g. robot007) will have a different %userprofile%\AppData\Local\UiPath means that UiPath.Service.Host service (running under LocalSystem) can not read license in profile of “robot007”

I changed the UiPath.Service.Host service to run under “robot007” and the message “To execute processes, please activate a license.” :slight_smile:

But I get another error: RemoteException wrapping System.Exception: Could not start executor. Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))

I believe this page might make it more clear:

Basically, for Community Edition it is always the User Mode Robot Service. The issue you are having is common whenever the two installers (Community and Enterprise) were once installed on one machine. This would result in two services (machine-wide and user-mode one) ‘colliding’ and thus causing unexpected behaviour.

I would definitely try again with the fresh install, removing all the files and then restarting the machine both after uninstall and after the fresh installation was completed (just to be sure all services are properly started).

One other cause of this issue can be an auto-update feature. During auto-update to the latest version, it can be that the user Robot service will get stuck on the older version while Studio is already running on the latest one. Typically a computer restart after the auto-update process will also fix this issue.

I suppose yet another cause would be if Studio cannot contact the licensing service while it is disconnected from Orchestrator.

I hope one of these ideas can help you with the solution here.

Thx for explanation. That means Community Edition can not coexist with UiPath.Service.Host service and therefore can not be used for Unattended Execution, right?

Not without some manual tweaks. When @Pablito is back from holidays, I’m sure he’ll be happy to provide you with some insights on how to get it to work with some powershell magic.
Basically, it is possible to create a machine-wide service using the Community Edition files, but it is not officially supported way due to several constraints (it can’t auto-update, if I were to list one, so you will need to manually run the script every time your Studio updates).

1 Like

I found quite simple solution:
1/ Change “license.config” file to store license in a “neutral” place where “user” and LocalSystem can reach it, e.g.
C:\Users\All Users\UiPath\License
C:\Users\All Users\UiPath\License

This needs to change in two places:
C:\Users<user>\AppData\Local\UiPath\app-
C:\Users<user>\AppData\Local\UiPath\app-\UiPath

2/ Install “UiPath Robot Service” service
run “UiPath.Service.Host.exe install”
note: Make sure that “UiPath.Service.UserHost” service is not running

3/ Activate trial license
run “regutil.exe activate /email=your@email.com”

4/ Restart “UiPath Robot Service”