To Execute Processes, please activate a license.-Community Edition

Hello Folks,
I am using a community edition of UiPath Studio. I am experiencing ‘To Execute Processes, please activate a license.’ with my edition. First time I experienced it, i uninstalled studio and reinstalled it. But again after installing it, i am getting the error. My dashboard in web is logged in and it is fine. Only when I click on ‘Run’ in studio I am getting this error. My device ID is cLwFfNL1cQ7Ek5/5BpKSIQ==.
Any pointers would be useful.
Thanks for the time and effort.

@PRADEEP_VR

Welcome to the UIpath Community.

Could you please check are you behind any firewall or are you using any Antivirus ? May be chances that it will block UIpath studio.

@lakshman
Thanks for the reply. I am not in any firewall and other than windows defender there is nothing else in my machine. The process was running yesterday after I installed it second time . But today when I started the studio, again I am getting this error. I clicked on Activate license/continue free from the home page.

2 Likes

@PRADEEP_VR can you share the screenshot ?

@vikaskulhari Thanks for your reply. I am uploading the screen shot. Please let me know if you are able to see the error message./
Thanks

Facing same issue! Was working earlier.

@PRADEEP_VR

Could you please go to help section page and show me once.

Hello @PRADEEP_VR
Once restart your system
I am also face same issue it’s solved when I restart my system

Thanks

2 Likes

@lakshman
Thanks Lakshman. I am attaching the snapshot of my Help page.

Thanks for the time and effort.

2 Likes

@sandeep13
Thanks Sandeep for the suggestion. I will try restarting the machine in a while and I wil update the status here.

1 Like

@sandeep13 I just restarted my machine and it works fine now. But one thing I am not sure is, everytime this happens either should I uninstall studio and reinstall it or restart the machine every single time.
Could you please let me know a fix for this problem if you are aware of any…
Thanks

1 Like

It will automatically fix by uipath shortly I think

1 Like

I faced the issue again. I restarted the machine and it worked fine. But could you please guess whats the cause for this issue with the studio.

I have no idea about that.
@loginerror @Pablito guys please help on this

Thanks

1 Like

It might be related to Studio auto-updating but the processes for the Robot not re-launching properly. This would explain why a simple computer restart helped here -> it restarted the new process for the robot.

I would certainly first try the restart if the issue occurs again. Only then reinstall from the latest installer.

1 Like

Still facing same issue. Has anyone found a solution besides machine restart? Please help!

Hi @SRay

Normally the solution to restart the machine needs to be applied only once, assuming the error comes from the wrong version of service running in the background (the restart would let it launch the latest version and that’s it, should work from there).

Another solution, which assumes the service is not the core issue here, is to connect your Robot (search Start menu for it) to Community Orchestrator and license your Studio this way.
See here for the way:

1 Like

Ok… this is crazy… but this is what i have tried & seems to be working. There is a file UiStudio.v2.settings in the UiPath folder. Whenever it gives an error, go & delete the file. DOES NOT require to restart Studio!!

Hi @loginerror,
I reuse this post.

I face the same issue in 2019.7 Community when the robot service UiPath.Service.Host is installed and disconnected from Orchestrator.

Studio starts just fine using the “Internal” license provider but any attempt to run a process I receive the error message like in subject.

Regutil returns the following license info:
License code: NALPNA
License status: 2
Device id: eue4pAk5+AAT14xN3IBS
License expire date: 12/6/2019 6:04:08 PM
Maintenance expire date: not set
Subscription expire date: not set
Attended: 0
Unattended: 30
Free: 0
Dev: 0
AttendedConcurrent: 0
DevConcurrent: 0

Any idea?

Hi @J0ska

Is it possible that you had the Enterprise version installed as well on the same machine?

Normally all licencing issues with the Community Edition are easily fixed with a fresh installation of Studio: