How to fix your Studio installation / Licensing issues

How to fix your Studio installation / Licensing issues

If you encounter an issue with your Studio installation and or licensing issues, please follow the below procedure to re-install the most recent stable version of Studio.

  1. Before you start, you might want to backup your settings.
    Please follow this guide on how to do it:
    Studio Community Edition - how to properly backup your settings

  2. Install all latest Windows Updates.

  3. Uninstall Studio from Apps & Features menu:

  4. Navigate to these folders and make sure to delete any leftover files

    rmdir /s /q "C:\Program Files (x86)\UiPath"
    rmdir /s /q "C:\Program Files (x86)\UiPath Platform"
    rmdir /s /q "C:\Program Files\UiPath"
    rmdir /s /q "C:\Program Files\UiPath Platform"
    rmdir /s /q C:\ProgramData\UiPath
    rmdir /s /q %APPDATA%\UiPath
    rmdir /s /q %APPDATA%\NuGet
    rmdir /s /q %LOCALAPPDATA%\Temp\nuget
    rmdir /s /q %LOCALAPPDATA%\Temp\NuGetScratch
    rmdir /s /q %LOCALAPPDATA%\NuGet
    rmdir /s /q %LOCALAPPDATA%\UiPath
    rmdir /s /q %APPDATA%\Roaming\UiPath
    rmdir /s /q %USERPROFILE%\.nuget
    
  5. Get your latest Stable Studio Community Edition .exe installer from here:
    https://platform.uipath.com/portal_/resourceCenter
    image

  6. After installation, you get a few choices to license your Robot. The most foolproof method is to connect your Robot to Orchestrator. For that, see here.
    Another method is to activate your license online.

This should fix your issues with the corrupted Studio installation, including any licensing issues.

Feel free to also refer to this topic in case your Studio auto-updates and stops working correctly:


(the fix for that is typically a simple computer restart)

25 Likes
Unable to activate/renew community edition licence
No longer able to Open UiPath Studio and run Bot's
Problem when I try to renew Uipath Studio Community License
Why Studio is not working properly
Open Document Error - UiPath.Studio.Contracts.RecoverableException
Error ERROR Validation Error Cannot access a disposed object
How can I properly uninstall UiPath community in order to fix UI Explorer?
After Connecting to DB ,Open Broswer Activity throwing below error. Tried in 19.3 version and 20.4 version Community Edition
[Action Needed] Community Edition licenses migration to Studio Pro license type / offering
Community Orchestrator will soon be upgraded with Studio Pro Community licenses
Reinstallation issues
Run UiRobot process from Windows 10 Task Scheduler
Error detecting uipath version
Uipath Unexpected character encountered while parsing value: <. Path '', line 0, position 0
Not able to see recording option into UIPath studio. Please help me to enable that
Unable to connect to orechestrator. Getting below Error:
Level 2-1 Orchestrator Publish Issue
Robot won't license itself when connecting to Orchestrator
Empty orchestrator
Orchestrator Lesson Practice 2
Studion Community Edition 2010.10 update error
Error open
Not able to kill jobs which are stopped
Just updated to the latest 2019.9.2 version studio window is transparent
How to fix errors after Studio Community Edition auto-updated from 2019.8 to 2019.9
Orchestrator Lesson Practice 2
Getting Error popup "A task was canceled" while connecting Uipath and orchestrator
Ui Path 2019.8.0 version gets hanged after update
I cannot open file, and start UiPath
To execute the process please activate the license
Why Uipath 19.8 v is very slow
Installation Everytime
To Execute Processes, please activate a license.-Community Edition
Lesson 5 Practice 3 - Unable to click menu options with click activity
Getting error while activating UiPath Studio community edition. we have not installed any trial version previously. Error: "Unexpected character encountered while parsing value: <. Path '', line 0, position 0"
Unable to execute process in UiPath studio
Invalid Ui Node error
UIPath Orchestrator lesson 7 does not work at all
Create process error
Licensing Issue 2100
Activities Search Feature
Studio 20918.7.0 selector not returning HTML tags after upgrade
Issues with MS 1903 Update
No endpoint listening at net.pipe://localhost/UiPath/service/duplex/agent/<USER> that could accept the message
Error detecting project version for scheduled orchestrator jobs
UiPath Design Studio 2019.6.0 Log Message Doesn't work
Input arguments are not showing in package.json or cloud orchestrator
Error creating a new project
Running does not work most of the time
The debugger does not work at all
Error detecting project version
Project Version Error
Error detecting project version (Don't worry I have found the solution and mentioned in this post)
Error in version 2019.7.0 open the exercice 5.1 (Nivel 1 - Desarrollador de RPA: formación básica - Actualizado)
Erro Renovação - Trial
Unable to use activities in UiPath after new Version 2019.5.0 update
Workflow editing restricted even with no robots running
Renew customer license
License expired for community edition
Studio Uninstalled itself and now needs a License Key
Community edition Active
Studio giving error
Community Edition License activation v19.5
UiPath won't activate
UiPath Studio Crashes after launch
UIPath Community Edition - Renew License Err - Please help
Not able to activate free licence key
Getting Activation Error while trying to use community edition
Studio Community Renew - Error code:0
UiPath Studio Crashes after launch
Error Connecting to Robot Services
Project.json couldn not be opened: illegal characters in path
Could not connect to UIPath Robot service.make sure the service is started
Designer Panel Missing - Cannot place windows in MDI since no MDI host was located at the direct child of the DockSites workspace
UiPath.Studio.Contracts.RecoverableException: The project could not be opened
Error when running Studio as Admin
Error System.IO.FileNotFoundException: Could not load file or assembly. The specified module could not be found
Studio does not run on desktop
Installing UiPath - missing UiRobot service (18.1.3)
UiPath Community 20.6 Preview Release
Automation Cloud - Licenses migration to Studio Pro for all Community users
UI Path Comunity edition "Server Licenced expired"
UI Path Comunity edition "Server Licenced expired"

Great @loginerror

it was required to put this solution on the top of the forum.many people face this problem

thanks

4 Likes

We are currently investigating why it happened in the first place. Hopefully the guide will help anybody affected.

4 Likes

We went ahead and followed the process mentioned above but the problem is still not resolved. Kindly assist.

3 Likes

Hi @loginerror,

Thanks for the update it really helps :smiley:

4 Likes

Hi @Botkeeper

Welcome to our UiPath Forum! :slight_smile:

Could you maybe follow this procedure and provide the output .zip file?

5 Likes

Wow… this is great… Thank you @loginerror… We noticed lot of licensing problems reported by many users since yesterday. This would help them alot…

Thanks :slight_smile:

5 Likes

Majority of the licensing problems can be fixed with this post.
Great @loginerror

Regards,
Karthik Byggari

5 Likes

I solved the licensing issue just deleting “LicenseInternal” and “License” folders without uninstalling Studio.

After starting Studio again the folders where re-created and I just needed to activate the community license. That way there’s no need for backups and new installations.

6 Likes

I solved the licence issue by downloading the new version 2019.6 in platform.uipath.com

5 Likes

I was helped by this post and solved the issue. :smiley::v:

Thank you @loginerror

6 Likes

Is there any update on this? Still we are facing issues

Thanks,
Vishal Kumar

1 Like

I’ve continued with this problems, ecach time I have the error with the activation. I am not able to run sucessufully my process

1 Like

I have reinstalled many times but still facing issues in executing the workflow. Please advise

1 Like

Hello,
As @Derek_Yap, i still facing this issue.
Thank you for your help

1 Like

Hi,
I am using a licensed version of UiPath studio. But Iam not able to RUN my developed bot. the studio is getting stuck and freezes, even Message Box activity Iam not able to execute.
When i checked in the Help option, my device Id was showing blank.
Is there any solution for this kind of problems?
Thanks In advance

Hi @shrunga15

This is most likely due to a corrupted installation (probably due to Studio being closed while autoupdating in the background).

Fresh installation should fix your issue. Please install the latest 2019.10.0 Stable release :slight_smile:

1 Like

@loginerror Thank you. I will try to do the same:)

hi Sir,
In this Below URL which One I need to Download i.e., “Community Edition” or “Enterprise Edition”, little bit Confused, henceforth Need to be Cleared…
https://cloud.uipath.com/infoldntdwyy/portal_/resourceCenter