SOAP Request - maybe HTTP Request - To Navision 2018 Soap webservice

Hi,

I’m struggling a lot trying to make calls to our Navision ERP, but I might not have the needed knowledge do fully understand what happens or where it fails.

I’ve tried searching the forum and google for tutorials and solutions, but I don’t think it’s actually helping me.

Where should I start to learn the basics of API calls? What is the mininmum to begin the work with API?
What is the normal procedure when trying to establish connections in UiPath?

And just for my understanding and clarification :slight_smile:
Am I correct if I assume that the method in UiPath is these in SoapUI?

To be more specific I encounter the following issues when trying.

First of all, all the calls can be made in SoapUI, and Navision responds as expected.
This is how it looks in SoapUI

If I use Soap request in UIPath

I get this,

When trying to invoke I get this error;
image

My guess is that it’s because of the authentication is not done, in SoapUI I’m typing in User, Pass AND domain -where should that be done in the SOAP request, in the body, header or a third place?

As a sidenote - if I don’t invoke and just closes the wizard and tries to run the activity, I get an error saying - The HTTP Request is unathorized with client authentication scheme ‘Anonymous’. The authetication header received from the server was ‘NTLM’ - is this handled in Uipath by sending the authentication along the request or is it handled on the server?

When I actually receive an answer, what is the approach to take?
Make a Soap Request with method “read”, get the answer and parse it like an XML, and return the answer how? a new SOAP request with method “update” how should the parameters be, the body and the header as well?

In SoapUI the response on read is as below, then the responses can be copied and sent back as an “update” which is seen below the read response

And to send the information back the reponse on read I put in the responses in this


Which updates Navision succesfully.

I’m really stuck on this, I can make it work in Soap but no matter what I try in UiPath it fails.

Iv’e tried following the steps in this link, but it gives me new errors which isn’t getting any further

As far I know, UiPath will work on this type of URL’s , but seems there are lot of issues with the web service URL if it is not a WSDL. Not sure about this. And can you please let me know if the URL is working fine in browser?

I must admit that I’m really struggling comprehending this topic, if you mean that it is working in a browser if I call type it in and get a response then yes, I get a full response in Chrome when typing in the URL.

Whats the difference between this service and a WDSL?

Hi @Michaeljep

Please see our documentation instead:

In short, the SOAP pacakge is a bit outdated while the Library services support is brand new.

This is why it will be more robust to use this new feature.

To do so, all you need is the definition file that you can provide in Studio. From then, you will end up with an activity for each of the end points.

You can then use these activities to produce your custom activities (for example, 1 xaml file per 1 endpoint within that library project)

With that, you can make it so that when you publish that library and install it in any project you want, you will have activities to activities for each endpoint :slight_smile:

To give you a short description about the wsdl, the web service URL will be the same as the web application URL without the query parameter WSDL. Most web services framework will add that query param wsdl at the end to let the users know, wsdl that is generated by the framework.

Hi @Michaeljep,

Were you able to solve the issue?

If so, can you tell what have you done to solve the issue?

I’m having the exact same issues that you have with another Web Service and it would be really great if you could help with this issue.

Thanks

Hi Thiago

I’ll write my solution later today when I’m at a computer again.

Cheers

-------- Oprindelig besked --------

1 Like

Hi

My solutions was like below.
Input as below

image

In soapUi I got the SoapAction and made a header in Ui with the same line.

The headers (1) in Ui is set to be as a String with the name (2) SOAPAction and with the line from the webservice from SoapUi (3)

The body from SoapUi is “converted” from XML to a string in double cuotes “String”
image

Attatchments, Cookies and Parameters is all empty.

Hope you will get it to work.

Cheers

2 Likes

Hello,

Trying to emulate what you have done to make yours work!

Here is the soap I am trying to access:

http://www.aaacooper.com/ws/ActDocumentSearch.asmx?wsdl

It works using the following XML

I have set up my HTTP request activity as follows, but i think i am missing something with the header. What do you think?

The body is the full XML string

This is what I have for headers

Lastly, this is what is being outputted.
image

Where am I going wrong!?
Thanks

Hi

Your header is wrong, if you look at mine it ends with :read - could also be update or delete.

So try make the call in SoapUI and copy paste the soap action from the properties from there.

Hi there,

Added :GetDocument to the end of my SOAPAction - still not the right output

image

Hi Michael,

I was able to get it to work in SoapUI without any headers - just the xml in the body.

In UiPath I pasted the xml in the body and changed the content type to text/xml and it now works!

1 Like

I try all the steps correctly. But I received the full xml in our response.
The Response from Uipath

I called the HTTP Request as below.
1.
request1

request2

Is there any point what I wrong?

Thank you so much for your kindness help.

You need to use SOAP activity here to call a WSDL url, not http request @khin

hi, i have the same problem, but can´t use SOAP request because doesn´t work because doesn´t show all fields of the request, and i am try whith HTTP Request but with POST and GET the outputted is the same (image),
can you help me, please?