Selector Finds element on creation, but fails to find on validate or execution

Hi guys,
I have a process that was working fine 2 days ago (had 24 successful scheduled runs) but now i cannot get it to find the 1st Type Into Selector, no matter what i do. I am using a Type Into inside of an Attach Browser after i Maximize Window. Here’s the breakdown.

  1. The Page:

  2. The field i’m trying to Type Into:

  3. The Type Into step and the Selector it selects:

Notice above that directly from the SELECT, it fails to validate (Red Validate button)

  1. When I try to re-select by Indicating Element, initially “Validate” is GREEN, however when clicking it a 2nd time, it is invalid again, also the link to “Open in UI Explorer” becomes grayed out and i cannot go in to work on it:

I am unsure of what to do here. It wont let me in to the UI Explorer so i can try to select it correctly, but also i am unsure of WHAT to select inside of UI Explorer when i am there as well. Any help is appreciated.

Hi @MickBisson

Go to launch hi explorer and check it out the selector with aaname property

Ashwin S

It seems to have a fixed field so you can use the label as an anchor (in the UIExplorer) and find that field, if you arent able to do that, revert and I will explain the steps. it should be easy enough.

Label - User and use indicate anchor for the same and then have one propert in selectors for the text fields without any idx or ID attribute and it should work surely

In UI Explorer immediately upon clicking “repair”, this selector has no AAName, and there are about 20 other parent selectors i can select. I have tried selecting a few or all of the parent’s, but it either has no effect or crashes.

Thank you, I have tried to select the User Label as an Anchor, but it fails to validate. Here is what the Selector looks like with “User” as an Anchor:

I think css selector might be causing an issue along with the idx. Why dont you share the full selected as well as unselected items from the right pane, it must have text/aaname property attribute

The tag of ‘type’ and ‘input’ should be enough I feel for the anchor based element. Is it a frame by any chance?

Ok here is the full selector with Anchor and the “css-selector” and which elements are selected in the hierarchy

And here are the elements broken down for each on the Right panel:
the TOP one:

The 2ND ONE:

The 3RD ONE () is empty

the ACTUAL SELECTOR for the field:

The only one of these tags with an AAName is the 2nd one. I validated it in UI Explorer, however when i go back to the Selector Editor: it is still invalid. Notice that AAName is highlighted, and it still cannot validate:

Kindly try with SEND HOT KEY activity and TYPE INTO ACTIVITY
—the sequnce would be like once after mentioning the url in OPEN BROWSER activity use SEND HOT KEY activity without selecting any element and use key as tab to navigate across the fields like how we do with keyboard alone without using mouse to navigate in a application
—and likewise use n number of send hot key with key as tab and once after reaching the field we want use TYPE INTO activity and mention the input string to be typed in without selecting the element we want
—and Along with the string mention the hotkeys as well like this once after reaching username field
“Your username”+”[k(enter)]”
And in this case enable Sendwindowmessage property in the property panel of type into activity and disable simulate type property

Similarly for password field also

Kindly try this and let know for any queries or clarification
Cheers @MickBisson

I believe i understand what you’re requesting and it doesn’t appear to work either, though for different reasons. Please check my work below.

I have simplified my process to just open the browser to the website, tab to get to fields, enter data and tab to next field. In this instance, nothing happens and no errors appear. The Website is opened but no text ever gets entered, and i also don’t see the Tab cycling through the 2 fields. I should mention that the website auto-tab’s to the next field when the one field gets its data, so that is why i have no Tab event after “ITG130TEST”. In either case, nothing ever gets typed into.

Is there anyway I can access the login page only?


Have you used “rowName” in your Type-into Selector?.

@Raghavendraprasad : unfortunately it is an internal only website, so you will be unable to access the site.

@Shivaraju : I have, but am still experiencing the issue where the selector wont validate. It validates in UI Explorer, but immediately invalidates when going back:

I have to “Repair” and reselect the element on the page in order to validate it again.

Give rowName=“User*” in Selector Editor.

Thanks Shivaraju,
I have tried this but the selector still fails to validate:

I have noticed an issue, but am unsure how to act on it. I have been having all of these Selector issues while working directly on my UI Path Test Server. I took this package i was working on to my local machine instead of the Server and i am now able to see and validate all of my Selectors.
So the issue here appears to be due to my remote server, however i am unsure of what to do in this situation. I cannot run the package on my local machine, and when it comes time to Publish this package and run it through Orchestrator, it will still continue to fail as it will be running ON the remote server.
This issue has only been present for a few days (since maybe Thursday last week (11/21).

Remove the id attribute in selector

@Shivaraju I have removed the ID tag, kept the rowName tag with ‘User*’ as the value, and the selector continues to not validate:

I should mention that it DOES validate IN the UI Explorer, but once i exit the Explorer, it fails to validate.

keep tableRow and tableColumn Values in Selector.

I have done the following:
1. Indicated the “User*” label NEXT to the field as an Anchor:

 2. I have altered the RowName field to say "User*" instead of "User                 "
 3. I have removed the ID attribute
 4. I have added the tableCol and tableRow elements
 5. I have tried this both WITH and WITHOUT the ID attribute of "in_453_10"

Per screenshots below, the field Validates on the UI Explorer, but immediately INVALIDATES on the Selector settings, and i still get the error that it cannot find Selector when running: